diff mbox series

[bug#70169,v2,11/12] maint: Reset CreationDate metadata on generated PDFs.

Message ID 87sezxdqdt.fsf@gnu.org
State New
Headers show
Series None | expand

Commit Message

Janneke Nieuwenhuizen April 7, 2024, 5:38 p.m. UTC
pelzflorian (Florian Pelz) writes:

Hi!

> Janneke Nieuwenhuizen <janneke@gnu.org> writes:
>> diff --git a/doc/local.mk b/doc/local.mk
>> index a0d94614d3..25741a5c88 100644
>> --- a/doc/local.mk
>> +++ b/doc/local.mk
>> @@ -148,7 +148,11 @@ DOT_OPTIONS =					\
>>  	$(AM_V_at)mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
>>  
>>  .dot.pdf:
>> -	$(AM_V_DOT)$(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"
>> +	export TZ=UTC0;								\
>> +	    $(AM_V_DOT)$(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"
>
> I see a non-fatal message here that
>
>     @echo " DOT " doc/images/bootstrap-graph.pdf;/bin/sh
> '/home/florian/src/guix/test70169/build-aux/missing' dot -Tpdf
> -Gratio=.9 -Gnodesep=.005 -Granksep=.00005 -Nfontsize=9 -Nheight=.1
> -Nwidth=.1 < "doc/images/bootstrap-graph.dot" >
> "./doc/images/bootstrap-graph.pdf.tmp"
> /bin/sh: line 2: @echo: command not found
>
> Perhaps AM_V_DOT cannot be used after export TZ=UTC0;?

Ah, that's not good.  Apparently I ontly tested using V=2 in the end.

I believe this should fix it


Greetings,
Janneke

Comments

Janneke Nieuwenhuizen April 7, 2024, 6:09 p.m. UTC | #1
Janneke Nieuwenhuizen writes:

Hi again,

> pelzflorian (Florian Pelz) writes:
>
>> Janneke Nieuwenhuizen <janneke@gnu.org> writes:
[..]
>> Perhaps AM_V_DOT cannot be used after export TZ=UTC0;?
>
> Ah, that's not good.  Apparently I ontly tested using V=2 in the end.
>
> I believe this should fix it

Come to think of it, as we're removeing CreationDate anyway, setting TZ
is quite unnecessary, and we can just do

.dot.pdf:
	$(AM_V_DOT)$(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"
[..]

Thanks for looking into this!
diff mbox series

Patch

diff --git a/doc/local.mk b/doc/local.mk
index fffba409dc..0cdad3e58c 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -148,8 +148,8 @@  DOT_OPTIONS =					\
 	$(AM_V_at)mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
 
 .dot.pdf:
-	export TZ=UTC0;								\
-	    $(AM_V_DOT)$(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"
+	$(AM_V_DOT)export TZ=UTC0;					\
+	    $(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"
 	$(AM_V_at)sed -ri					\
 	    -e 's,(/CreationDate \(D:).*\),\119700101000000,'	\
 	    "$(srcdir)/$@.tmp"