[bug#74329,10/10] gnu: Fix whitespace issues in Tex package descriptions.

Message ID 87sepxq6i8.fsf@erlikon.ch
State New
Headers
Series Extensively lint descriptions and synopses. |

Commit Message

Gabriel Wicki Jan. 5, 2025, 9:24 p.m. UTC
  This mainly addresses `double-space after sentence end period' and `trailing
white space' issues.

* gnu/packages/tex.scm (texlive-jablantile, texlive-pmhanguljamo,
texlive-urcls, texlive-optexcount, texlive-pdfjam, texlive-pst-geo,
texlive-keyfloat, texlive-marginfit, texlive-pas-tableur): Fix description.

Change-Id: Ib49a0d3a753d21982630445a95a8651b1cadf26a
---
 gnu/packages/tex.scm | 50 ++++++++++++++++++++++----------------------
 1 file changed, 25 insertions(+), 25 deletions(-)
  

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 96f5756f2d..bfc923c8e3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21938,7 +21938,7 @@  (define-public texlive-jablantile
     (synopsis "Metafont version of tiles in the style of Slavik Jablan")
     (description
      "This is a Metafont font to implement the modular tiles described by
-Slavik Jablan. ")
+Slavik Jablan.")
     (license license:public-domain)))
 
 (define-public texlive-jacow
@@ -31177,7 +31177,7 @@  (define-public texlive-pmhanguljamo
     (synopsis "Poor man's Hangul Jamo input method")
     (description
      "This package provides a Hangul transliteration input method that allows
-to typeset Korean letters (Hangul) using the proper fonts. The use of XeLaTeX
+to typeset Korean letters (Hangul) using the proper fonts.  The use of XeLaTeX
 is recommended.")
     (license license:lppl1.3+)))
 
@@ -39170,7 +39170,7 @@  (define-public texlive-urcls
      "The bundle provides a Beamer-derived class and a theme style file for
 the corporate design of the @acronym{UR, University of Regensburg}.  It also
 contains a @code{scrlttr2}-derived class for letters using the corporate
-design of the UR. Users may use the class itself (URbeamer) or use the theme
+design of the UR.  Users may use the class itself (URbeamer) or use the theme
 in the usual way with @code{\\usetheme@{UR@}}.")
     (license license:lppl)))
 
@@ -48882,7 +48882,7 @@  (define-public texlive-optexcount
     (synopsis "Python script for counting words in OpTeX documents")
     (description
      "OpTeXcount is a basic Python utility that analyzes OpTeX source code.
-It is inspired by already existing TeXcount for LaTeX. The functionality is
+It is inspired by already existing TeXcount for LaTeX.  The functionality is
 really lightweight and basic.  It counts words and other elements of OpTeX
 document and sorts them out into individual categories.  Users can print the
 source code with highlighted words using several colors, so they see what is
@@ -49028,7 +49028,7 @@  (define-public texlive-pdfjam
     (description
      "The package makes available the @command{pdfjam} shell script that
 provides a simple interface to much of the functionality of the excellent
-@code{pdfpages} package for LaTeX. The @command{pdfjam} script takes one or
+@code{pdfpages} package for LaTeX.  The @command{pdfjam} script takes one or
 more PDF files (and/or JPG/PNG graphics files) as input, and produces one or
 more PDF files as output.  It is useful for joining files together, selecting
 pages, reducing several source pages onto one output page, etc.")
@@ -75713,7 +75713,7 @@  (define-public texlive-pst-geo
 @code{pst-map2d} provides conventional projections such as Mercator, Lambert,
 cylindrical, etc.  The package @code{pst-map3d} treats representation in three
 dimensions of the terrestrial sphere.  Packages @code{pst-map2dII} and
-@code{pst-map3dII} allow use of the CIA World DataBank II. Various parameters
+@code{pst-map3dII} allow use of the CIA World DataBank II.  Various parameters
 of the packages allow for choice of the level of the detail and the layouts
 possible (cities, borders, rivers etc).  Substantial data files are provided,
 in an (internally) compressed format.  Decompression happens on-the-fly as
@@ -108071,20 +108071,20 @@  (define-public texlive-keyfloat
     (home-page "https://ctan.org/pkg/keyfloat")
     (synopsis "Provides a key/value interface for generating floats")
     (description
-     "The @code{keyfloat} package provides a key/value user interface for quickly
-creating figures with a single image each, figures with arbitrary contents,
-tables, subfloats, rows of floats, floats located ``here'', floats in the
-margin, and floats with text wrapped around them.  Key/value combinations may
-specify a caption and label, a width proportional to @code{\\linewidth},
-a fixed width and/or height, rotation, scaling, a tight or loose frame, an
-@code{\\arraystretch}, a continued float, additional supplemental text, and an
-artist/author's name with automatic index entry.  When used with the
-@code{tocdata} package, the name also appears in the list of figures.  Floats
-may be placed into a @code{row} environment, and are typeset to fit within the
-given number of columns, continuing to the next row if necessary.  Nested
-sub-rows may be used to generate layouts such as two small figures placed
-vertically next to one larger figure.  Subfloats are supported by two
-environments.")
+     "The @code{keyfloat} package provides a key/value user interface for
+quickly creating figures with a single image each, figures with arbitrary
+contents, tables, subfloats, rows of floats, floats located @emph{here},
+floats in the margin, and floats with text wrapped around them.  Key/value
+combinations may specify a caption and label, a width proportional to
+@code{\\linewidth}, a fixed width and/or height, rotation, scaling, a tight or
+loose frame, an @code{\\arraystretch}, a continued float, additional
+supplemental text, and an artist/author's name with automatic index entry.
+When used with the @code{tocdata} package, the name also appears in the list
+of figures.  Floats may be placed into a @code{row} environment, and are
+typeset to fit within the given number of columns, continuing to the next row
+if necessary.  Nested sub-rows may be used to generate layouts such as two
+small figures placed vertically next to one larger figure.  Subfloats are
+supported by two environments.")
     (license license:lppl1.3+)))
 
 (define-public texlive-keyindex
@@ -110618,10 +110618,10 @@  (define-public texlive-marginfit
     (home-page "https://ctan.org/pkg/marginfit")
     (synopsis "Improved margin notes")
     (description
-     "This package fixes various bugs with the margin paragraph implementation of
-LaTeX. Those bugs include margin notes that are attached to the wrong side as
-well as those that stick out of the bottom of the page.  This package provides
-a drop-in replacement solution.")
+     "This package fixes various bugs with the margin paragraph implementation
+of LaTeX.  Those bugs include margin notes that are attached to the wrong side
+as well as those that stick out of the bottom of the page.  This package
+provides a drop-in replacement solution.")
     (license license:lppl1.3+)))
 
 (define-public texlive-mathexam
@@ -114580,7 +114580,7 @@  (define-public texlive-pas-tableur
     (synopsis "Create a spreadsheet layout")
     (description
      "The package provides commands for creating a grid of rectangles, and commands
-for populating locations in the grid. PGF/TikZ is used for placement and
+for populating locations in the grid.  PGF/TikZ is used for placement and
 population of the cells.")
     (license license:lppl)))