diff mbox series

[bug#40048] Add barrage game

Message ID 87r1xwj1ft.fsf@posteo.mx
State Accepted
Headers show
Series [bug#40048] Add barrage game | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alberto EFG March 13, 2020, 4:58 a.m. UTC
Hello.

My second patch, I tried to avoid the same mistakes of the last one.
Everything seems to work.
guix size is around 800 MB

Please let me know of any mistakes I made :)

Comments

Nicolas Goaziou March 13, 2020, 8:46 p.m. UTC | #1
Hello,

Alberto EFG <albertoefg@posteo.mx> writes:

> My second patch, I tried to avoid the same mistakes of the last one.
> Everything seems to work.
> guix size is around 800 MB

I applied the patch with the changes below:

> +    (inputs
> +     `(("sdl" ,sdl)
> +       ("sdl-mixer" ,sdl-mixer)
> +       ("hicolor-icon-theme" ,hicolor-icon-theme)))

I re-ordered inputs alphabetically.

> +    (synopsis "Violent point-and-click shooting game with nice effects")
> +    (description "Barrage is a rather destructive action game that
> + puts you on a shooting range with the objective to hit as many dummy
> + targets as possible within 3 minutes.  You control a gun that may either
> + fire small or large grenades at soldiers, jeeps and tanks.
> + Targets are fast pace.")

The last sentence seemed to be cut off. I changed the ending according
to upstream REAMDE.

Thank you!

Regards,
Vincent Legoll April 13, 2020, 4:35 p.m. UTC | #2
Hello,

I think this issue should be closed

WDYT ?
Nicolas Goaziou April 13, 2020, 4:52 p.m. UTC | #3
Hello,

Vincent Legoll <vincent.legoll@gmail.com> writes:

> I think this issue should be closed
>
> WDYT ?

You are right. I forgot to do it. Thanks for the heads up.

Regards,
diff mbox series

Patch

From 74e954b5ef5caee3634be2067f32541a0f05c294 Mon Sep 17 00:00:00 2001
From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
Date: Wed, 11 Mar 2020 21:50:14 -0600
Subject: [PATCH] gnu: Add barrage.

* gnu/packages/games.scm (barrage): New variable.
---
 gnu/packages/games.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 322e309591..7581a429f8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -46,6 +46,7 @@ 
 ;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
 ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10157,3 +10158,34 @@  best human chess grandmasters.  It can be used with UCI-compatible GUIs like
 ChessX.")
     (home-page "https://stockfishchess.org/")
     (license license:gpl3+)))
+
+(define-public barrage
+  (package
+    (name "barrage")
+    (version "1.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/lgames/barrage/"
+                           "barrage-" version ".tar.gz"))
+       (sha256
+        (base32 "0139wxyrir10cbkvkjn548xgmp84wax8mfwk80yxbxlcdamrg257"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("sdl" ,sdl)
+       ("sdl-mixer" ,sdl-mixer)
+       ("hicolor-icon-theme" ,hicolor-icon-theme)))
+    (arguments
+     `(#:configure-flags
+       (list
+        (string-append "CFLAGS="
+                       "-I" (assoc-ref %build-inputs "sdl-mixer")
+                       "/include/SDL"))))
+    (home-page "http://lgames.sourceforge.net/Barrage/")
+    (synopsis "Violent point-and-click shooting game with nice effects")
+    (description "Barrage is a rather destructive action game that
+ puts you on a shooting range with the objective to hit as many dummy
+ targets as possible within 3 minutes.  You control a gun that may either
+ fire small or large grenades at soldiers, jeeps and tanks.
+ Targets are fast pace.")
+    (license license:gpl2+)))
-- 
2.25.1