diff mbox series

[bug#41949,5/5] gnu: Add gerbil-denatting

Message ID 87r1ub18iu.fsf@alice.lan
State New
Headers show
Series [bug#41949,1/5] gnu: Add gerbil | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Edouard Klein June 19, 2020, 1:37 p.m. UTC
* gnu/packages/scheme-xyz.scm: (gerbil-denatting): New variable.
---
 gnu/packages/scheme-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/scheme-xyz.scm b/gnu/packages/scheme-xyz.scm
index 8b553848ee..39991c5807 100644
--- a/gnu/packages/scheme-xyz.scm
+++ b/gnu/packages/scheme-xyz.scm
@@ -26,3 +26,37 @@  to a string.  It takes one object as the first argument and accepts a variable
 number of optional arguments, unlike the procedure called FORMAT.")
     (home-page "https://github.com/hckiang/srfi-54")
     (license license:lgpl3)))
+
+(define-public gerbil-denatting
+  (package
+    (name "gerbil-denatting")
+    (version "0.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/edouardklein/denatting.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0m8nlqjs1bqhs7cqdf9ddj9hnm9xfmngzd5iawc0fz3qamsw1wyp"))))
+    (propagated-inputs
+     `(("gerbil" ,gerbil)
+       ("xlsxio" ,xlsxio)
+       ("gerbil-srfi-54" ,gerbil-srfi-54)))
+    (build-system gerbil-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'wrap 'rewrap ;Allow denat to find xlsxio's shared object
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((denat (string-append (assoc-ref outputs "out") "/bin/denat"))
+                   (xlsxio (string-append (assoc-ref inputs "xlsxio") "/lib")))
+               (wrap-program denat `("LD_LIBRARY_PATH" = (,xlsxio)))))))))
+    (synopsis "Find who is hiding behind a mobile IPv4")
+    (description "Denatting is a Europol-backed project whose goal is to allow
+investigators in participating countries to discover which Internet Service Provider
+(ISP) client is responsible for a set of network events as reported by content
+providers within the legal framework of a judicial investigation.")
+    (home-page "https://gitlab.com/edouardklein/denatting")
+    (license license:agpl3+)))