diff mbox series

[bug#45050] gnu: Update emacs-guix to temporary repository.

Message ID 87r1o4lte7.fsf@asu.edu
State Accepted
Headers show
Series [bug#45050] gnu: Update emacs-guix to temporary repository. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Soo Dec. 5, 2020, 5:21 a.m. UTC
Hello Guix,

Since 1.2 was released, I can update emacs-guix to use my repository
with patches to make it work again. It should be updated again when
guix.el has a new home.

Kindly,

John

Comments

John Soo Dec. 5, 2020, 5:24 a.m. UTC | #1
Just one of those patches is required, sorry!
Simon Tournier Dec. 7, 2020, 4:01 p.m. UTC | #2
Hi John,

On Fri, 04 Dec 2020 at 21:21, John Soo <jsoo1@asu.edu> wrote:
> Hello Guix,
>
> Since 1.2 was released, I can update emacs-guix to use my repository
> with patches to make it work again. It should be updated again when
> guix.el has a new home.

News about the new home?

> +              (uri (git-reference
> +                    ;; TODO: Use the official version when it has a new home
> +                    (url "https://github.com/jsoo1/guix.el")

Is it the most recent version where patches are applied?


Cheers,
simon
John Soo Dec. 7, 2020, 4:15 p.m. UTC | #3
Hi zimoun,
  

  
I still haven’t heard from the original maintainer about moving the sources to savannah. I sent an email maybe a week or two ago.   
  

  
The source I added here does have patches applied to make it work. My goal is to switch the source again when it ends up wherever it finally finds a new official location.   
  

  
What do you think?
  

  
- John
Simon Tournier Dec. 7, 2020, 4:55 p.m. UTC | #4
Hi,

On Mon, 07 Dec 2020 at 08:15, John Soo <jsoo1@asu.edu> wrote:

> The source I added here does have patches applied to make it work. My
> goal is to switch the source again when it ends up wherever it finally
> finds a new official location.

Sounds good!

Cheers,
simon
Ludovic Courtès Dec. 11, 2020, 5:47 p.m. UTC | #5
Hi!

John Soo <jsoo1@asu.edu> skribis:

>>From 28abdd7140c31425f6add54470ad683bc46e8de7 Mon Sep 17 00:00:00 2001
> From: John Soo <jsoo1@asu.edu>
> Date: Thu, 12 Nov 2020 23:04:27 -0800
> Subject: [PATCH] gnu: Update emacs-guix.
>
> * gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
> guix.

If it fixes one of the bugs in the tracker, we can mention it in the
commit log with “Fixes <https://bugs.gnu.org/XYZ>.”

>  (define-public emacs-guix
> -  (let ((commit "58a840d0671091e3064e36244790ef8839da87d6")
> -        (revision "2"))
> +  (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
> +         (revision "1"))

Please increment the revision number rather than decrement it.

>      (package
> -      (name "emacs-guix")
> -      (version (git-version "0.5.2" revision commit))

Please don’t reindent, the original formatting was fine.  :-)

Could you send an updated patch?

I guess it’s fine to use your repo until we hear from Alex Kost.

Thanks for taking care of this!

Ludo’.
diff mbox series

Patch

From 28abdd7140c31425f6add54470ad683bc46e8de7 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 12 Nov 2020 23:04:27 -0800
Subject: [PATCH] gnu: Update emacs-guix.

* gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
guix.
---
 gnu/packages/emacs-xyz.scm | 70 ++++++++++++++++++++------------------
 1 file changed, 36 insertions(+), 34 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bf2312eb49..9523031095 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2795,41 +2795,43 @@  type, for example: packages, buffers, files, etc.")
     (license license:gpl3+)))
 
 (define-public emacs-guix
-  (let ((commit "58a840d0671091e3064e36244790ef8839da87d6")
-        (revision "2"))
+  (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
+         (revision "1"))
     (package
-      (name "emacs-guix")
-      (version (git-version "0.5.2" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://gitlab.com/emacs-guix/emacs-guix")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1qnr5sixmvrhr9rinrhfy7sy20mikjvvwbdixwkbx30qpcdwgwj1"))))
-      (build-system gnu-build-system)
-      (native-inputs
-       `(("autoconf" ,autoconf)
-         ("automake" ,automake)
-         ("pkg-config" ,pkg-config)
-         ("texinfo" ,texinfo)
-         ("emacs" ,emacs-minimal)))
-      (inputs
-       `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
-         ("guix" ,guix)))
-      (propagated-inputs
-       `(("geiser" ,emacs-geiser)
-         ("guile-gcrypt" ,guile-gcrypt)
-         ("dash" ,emacs-dash)
-         ("bui" ,emacs-bui)
-         ("edit-indirect" ,emacs-edit-indirect)
-         ("magit-popup" ,emacs-magit-popup)))
-      (home-page "https://emacs-guix.gitlab.io/website/")
-      (synopsis "Emacs interface for GNU Guix")
-      (description
-       "Emacs-Guix provides a visual interface, tools and features for the GNU
+     (name "emacs-guix")
+     (version (git-version "0.5.2" revision commit))
+     (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    ;; TODO: Use the official version when it has a new home
+                    (url "https://github.com/jsoo1/guix.el")
+                    (commit commit)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pqw7zbgxzwpig4xr0izc3z8h80c72i6bl5yi12br0d7aq6dbkvj"))))
+     (build-system gnu-build-system)
+     (native-inputs
+      `(("autoconf" ,autoconf)
+        ("automake" ,automake)
+        ("pkg-config" ,pkg-config)
+        ("texinfo" ,texinfo)
+        ("emacs" ,emacs-minimal)))
+     (inputs
+      `(("guile"
+         ,@(assoc-ref (package-native-inputs guix) "guile"))
+        ("guix" ,guix)))
+     (propagated-inputs
+      `(("geiser" ,emacs-geiser)
+        ("guile-gcrypt" ,guile-gcrypt)
+        ("dash" ,emacs-dash)
+        ("bui" ,emacs-bui)
+        ("edit-indirect" ,emacs-edit-indirect)
+        ("magit-popup" ,emacs-magit-popup)))
+     (home-page "https://emacs-guix.gitlab.io/website/")
+     (synopsis "Emacs interface for GNU Guix")
+     (description
+      "Emacs-Guix provides a visual interface, tools and features for the GNU
 Guix package manager.  Particularly, it allows you to do various package
 management tasks from Emacs.  To begin with, run @code{M-x guix-about} or
 @code{M-x guix-help} command.")
-- 
2.29.2