diff mbox series

[bug#46066,1/2] gnu: Add interception-tools.

Message ID 87r1mbt43m.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#46066,1/2] gnu: Add interception-tools. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

LaFreniere, Joseph Jan. 24, 2021, 3:18 a.m. UTC
Patch file attached.

--
Joseph LaFreniere

Comments

Ludovic Courtès March 27, 2021, 9:55 p.m. UTC | #1
Hi,

Joseph LaFreniere <joseph@lafreniere.xyz> skribis:

>>From 8eb7d142df5da842a98ade989ff14c625e51e8d9 Mon Sep 17 00:00:00 2001
> From: Joseph LaFreniere <joseph@lafreniere.xyz>
> Date: Sat, 23 Jan 2021 14:57:25 -0600
> Subject: [PATCH 1/2] gnu: Add interception-tools.
>
> * gnu/packages/linux.scm (interception-tools): New variable.

It fell through the cracks but now it’s pushed!

> +    (license (list license:gpl3 (license:non-copyleft "file://README.md")))))

I changed that to just gpl3+; ‘README.md’ describes some hypothetical
dual licensing, which I’ve mentioned in a comment.

Thanks,
Ludo’.
diff mbox series

Patch

From 8eb7d142df5da842a98ade989ff14c625e51e8d9 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sat, 23 Jan 2021 14:57:25 -0600
Subject: [PATCH 1/2] gnu: Add interception-tools.

* gnu/packages/linux.scm (interception-tools): New variable.
---
 gnu/packages/linux.scm | 45 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e0f056aff9..4112e9a00e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3463,6 +3463,51 @@  subsystem.  @code{uinput} allows userspace programs to create and handle input
 devices that can inject events directly into the input subsystem.")
     (license license:bsd-3)))
 
+(define-public interception-tools
+  (package
+    (name "interception-tools")
+    (version "0.6.4")
+    (home-page "https://gitlab.com/interception/linux/tools")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "121jy40ynkbzlqnx7g0dqwvkb7dm2ahcy6vwrz6ylsyd0jmi6s5a"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("boost" ,boost)
+       ("libevdev" ,libevdev)
+       ("libudev" ,eudev)
+       ("yaml-cpp" ,yaml-cpp)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-libevdev-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((libevdev (assoc-ref inputs "libevdev")))
+               (substitute* "CMakeLists.txt"
+                 (("/usr/include/libevdev-1.0")
+                  (string-append libevdev "/include/libevdev-1.0")))
+               #t))))
+       ;; No tests are included.
+       #:tests? #f))
+    (synopsis "Utilities for operating on input events of evdev devices")
+    (description
+     "Interception Tools provides a composable infrastructure on top of
+@code{libudev} and @code{libevdev}.  The following utilities are provided:
+
+@itemize
+@item udevmon - monitor input devices for launching tasks
+@item intercept - redirect device input events to stdout
+@item uinput - redirect device input events from stding to virtual device
+@item mux - mux streams of input events
+@end itemize")
+    (license (list license:gpl3 (license:non-copyleft "file://README.md")))))
+
 (define-public lvm2
   (package
     (name "lvm2")
-- 
2.30.0