diff mbox series

bug#52404: [PATCH] gnu: Add xblackjack.

Message ID 87r1a4z4oz.fsf@gnu.org
State Accepted
Headers show
Series bug#52404: [PATCH] gnu: Add xblackjack. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Dec. 22, 2021, 9:54 p.m. UTC
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

> * gnu/packages/games.scm (xblackjack): New variable.

Applied with the changes below, mostly to placate ‘guix lint’.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3e6aeec839..fa6865c050 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12253,7 +12253,7 @@  (define-public xblackjack
 
                ;; Fix compilation errors.
                (substitute* "Table.c"
-                 (("/\\* focus_moved_proc \\*/	XtInheritFocusMovedProc,") "")
+                 (("/\\* focus_moved_proc \\*/\tXtInheritFocusMovedProc,") "")
                  (("_XmMoveObject\\(\\(RectObj\\) w, rx, ry\\);")
                   "_XmMoveObject(w, rx, ry);")
                  (("_XmResizeObject\\(\\(RectObj\\) managed->locs[i].w, nw, nh,")
@@ -12263,13 +12263,9 @@  (define-public xblackjack
              (invoke "make" "install.man"))))
        #:tests? #f))  ; No check target.
     (inputs
-     `(("lesstif" ,lesstif)
-       ("libx11" ,libx11)
-       ("libxext" ,libxext)
-       ("libxmu" ,libxmu)
-       ("libxt" ,libxt)))
+     (list lesstif libx11 libxext libxmu libxt))
     (native-inputs
-     `(("imake" ,imake)))
+     (list imake))
     (home-page "https://www.ibiblio.org/pub/X11/contrib/games/")
     (synopsis "X11/Motif blackjack game")
     (description
@@ -12278,7 +12274,7 @@  (define-public xblackjack
 O. Thorp, Ph.D. of UCLA.  A number of important statistics are maintained
 for display, and used by the program to implement Thorp's \"Complete Point
 System\" (high-low system).")
-    (license license:x11-style)))
+    (license (license:x11-style "" "See file headers."))))
 
 (define-public azimuth
   (package