diff mbox series

[bug#52721] v2 gnu: python-pydata-sphinx-theme: Fix build.

Message ID 87r1a433my.fsf_-_@posteo.org
State Accepted
Headers show
Series [bug#52721] v2 gnu: python-pydata-sphinx-theme: Fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev Dec. 22, 2021, 6:17 p.m. UTC
Hi,
On 2021-12-22, 10:53 +0000, Maxime Devos <maximedevos@telenet.be> wrote:

>> the build fails because a package is required python-docutils < 0.17.
>
> Is python-docutils<0.17 truly required, or are the version requirements
> in the source code overly strict? If it's the latter, you could patch
> the source code to relax the requirements.
>
> The latter happens often, because library developers often don't know
> in advance whether the library is compatible with future versions of
> the dependencies.

For version 0.6.3 there is a file
pydata-sphinx-theme-0.6.3/docs/requirements.txt where the last line
contains:

docutils==0.16 # temporary pin (0.17 broken captions).

Also, the master version requires "docutils!=0.17.0.

So I created a patch that adds an extra phase.

Comments

M Dec. 22, 2021, 6:25 p.m. UTC | #1
Aleksandr Vityazev schreef op wo 22-12-2021 om 18:17 [+0000]:
> 
> > > the build fails because a package is required python-docutils <
> > > 0.17.
> > 
> > Is python-docutils<0.17 truly required, or are the version
> > requirements
> > in the source code overly strict? If it's the latter, you could
> > patch
> > the source code to relax the requirements.
> > 
> > The latter happens often, because library developers often don't
> > know
> > in advance whether the library is compatible with future versions
> > of
> > the dependencies.
> 
> For version 0.6.3 there is a file
> pydata-sphinx-theme-0.6.3/docs/requirements.txt where the last line
> contains:
> 
> docutils==0.16 # temporary pin (0.17 broken captions).
> 
> Also, the master version requires "docutils!=0.17.0.
> 
> So I created a patch that adds an extra phase.

In that case, docutil<0.17 appears to be actually required, so the
solution would be to use docutils=0.15 as you did originally, I think?
Preferably with a comment ; captions are broken in 0.17..

Greetings,
Maxime.
Aleksandr Vityazev Dec. 23, 2021, 10:54 p.m. UTC | #2
Hi,

On 2021-12-22, 18:25 +0000, Maxime Devos <maximedevos@telenet.be> wrote:

>> For version 0.6.3 there is a file
>> pydata-sphinx-theme-0.6.3/docs/requirements.txt where the last line
>> contains:
>> 
>> docutils==0.16 # temporary pin (0.17 broken captions).
>> 
>> Also, the master version requires "docutils!=0.17.0.
>> 
>> So I created a patch that adds an extra phase.
>
> In that case, docutil<0.17 appears to be actually required, so the
> solution would be to use docutils=0.15 as you did originally, I think?
> Preferably with a comment ; captions are broken in 0.17..
>

These were pushed by Efraim Flashner with
8efa775653f78dad8b254e719677e663be8f3240.
Efraim Flashner Dec. 25, 2021, 8:02 p.m. UTC | #3
On Thu, Dec 23, 2021 at 10:54:27PM +0000, Aleksandr Vityazev wrote:
> Hi,
> 
> On 2021-12-22, 18:25 +0000, Maxime Devos <maximedevos@telenet.be> wrote:
> 
> >> For version 0.6.3 there is a file
> >> pydata-sphinx-theme-0.6.3/docs/requirements.txt where the last line
> >> contains:
> >> 
> >> docutils==0.16 # temporary pin (0.17 broken captions).
> >> 
> >> Also, the master version requires "docutils!=0.17.0.
> >> 
> >> So I created a patch that adds an extra phase.
> >
> > In that case, docutil<0.17 appears to be actually required, so the
> > solution would be to use docutils=0.15 as you did originally, I think?
> > Preferably with a comment ; captions are broken in 0.17..
> >
> 
> These were pushed by Efraim Flashner with
> 8efa775653f78dad8b254e719677e663be8f3240.
> 

Sorry, I didn't check for patches before working on this patch.
diff mbox series

Patch

From 7301a82b07e73c3bdbeef0d1375094d625336766 Mon Sep 17 00:00:00 2001
Message-Id: <7301a82b07e73c3bdbeef0d1375094d625336766.1640196453.git.avityazev@posteo.org>
From: Aleksandr Vityazev <avityazev@posteo.org>
Date: Wed, 22 Dec 2021 17:25:18 +0300
Subject: [PATCH] gnu: python-pydata-sphinx-theme: Fix build.

* gnu/packages/sphinx (python-pydata-sphinx-theme):
[arguments]: add phase "relax-dependency-requirements".
---
 gnu/packages/sphinx.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 3ac5b5e22c..c9a9a2efbb 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -915,6 +916,13 @@  (define-public python-pydata-sphinx-theme
         (base32
          "055bh3hyh72pafiylvgpsjlk18wm15gg4azc5rjlsww5z475iq1j"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'relax-dependency-requirements
+           (lambda _
+             (substitute* "setup.py"
+               (("docutils<0.17") "docutils")))))))
     (propagated-inputs
      (list python-beautifulsoup4))
     (native-inputs
-- 
2.34.0