diff mbox series

[bug#50663] Add Mycroft - Voice Assistant

Message ID 87r18wbvnq.fsf@nicolasgoaziou.fr
State New
Headers show
Series [bug#50663] Add Mycroft - Voice Assistant | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Goaziou Jan. 24, 2022, 10:45 p.m. UTC
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> The aim of this patch set is to bring in the MyCroft - private and
> open Voice Assistant.

Thank you.

I fixed some descriptions, removed labels from inputs, fixed compilation
with GCC 10 (for Mimic). Then I tried to apply the patch set. Alas
Mycroft core fails to build. You may want to have a look at it.

I'm sending back the updated patches to you, if that helps.

Regards,
diff mbox series

Patch

From 51e054b823c60442317bc3487a0c769f14de9d1f Mon Sep 17 00:00:00 2001
Message-Id: <51e054b823c60442317bc3487a0c769f14de9d1f.1643064269.git.mail@nicolasgoaziou.fr>
In-Reply-To: <a8e11183ad26ec2bc601c5a4e8265a10ce52948e.1643064268.git.mail@nicolasgoaziou.fr>
References: <a8e11183ad26ec2bc601c5a4e8265a10ce52948e.1643064268.git.mail@nicolasgoaziou.fr>
From: Petr Hodina <phodina@protonmail.com>
Date: Fri, 30 Jul 2021 17:21:07 +0200
Subject: [PATCH v2 19/19] gnu: Add python-mycroft-core.

* gnu/packages/python-xyz.scm (python-mycroft-core): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
---
 gnu/packages/python-xyz.scm | 80 +++++++++++++++++++++++++++++++++++++
 1 file changed, 80 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4353797e83..1834152c3c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -210,6 +210,7 @@  (define-module (gnu packages python-xyz)
   #:use-module (gnu packages search)
   #:use-module (gnu packages serialization)
   #:use-module (gnu packages shells)
+  #:use-module (gnu packages speech)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages swig)
@@ -21968,6 +21969,85 @@  (define-public python2-more-itertools
     (propagated-inputs
      `(("python2-six" ,python2-six-bootstrap)))))
 
+(define-public python-mycroft-core
+  (package
+    (name "python-mycroft-core")
+    (version "21.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/MycroftAI/mycroft-core")
+         (commit (string-append "release/v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "02r0vxw0hsihnvviwn4fyspwky3kwq42f9z455q1s70k0snzhb28"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-requirements
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Use newer version of pkg
+             (substitute* "requirements/requirements.txt"
+               (("mycroft-messagebus-client==") "mycroft-messagebus-client>=")
+               (("tornado==") "tornado>=")
+               (("pyserial==") "pyserial>=")
+               (("psutil==") "psutil>=")
+               (("padaos==") "padaos>=")
+               (("precise-runner==") "precise-runner>=")
+               (("pocketsphinx==") "pocketsphinx>=")
+               (("python-dateutil==") "python-dateutil>=")
+               (("fasteners==") "fasteners>=")
+               (("requests-futures==") "requests-futures>=")
+               (("pillow==") "pillow>=")
+               (("PyYAML==5.4") "PyYAML>=5.3.1")
+               (("pyxdg==") "pyxdg>=")
+               (("requests>=2.20.0,<2.26.0") "requests>=2.20.0"))))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (setenv "PYTHONPATH"
+                       (string-append "./build/lib:"
+                                      (or (getenv "PYTHONPATH")
+                                          "")))))))))
+    (inputs (list mycroft-mimic pocketsphinx))
+    (propagated-inputs
+     (list python-fasteners
+           python-inflection
+           python-pyxdg
+           python-mycroft-messagebus-client
+           python-psutil
+           python-tornado-6
+           python-petact
+           python-precise-runner
+           python-padaos
+           python-speech-recognition
+           python-padatious
+           python-msk
+           python-pillow
+           python-gtts
+           python-requests-futures
+           python-pyserial
+           python-pocketsphinx
+           python-adapt-parser
+           python-lingua-franca
+           python-pyyaml
+           python-fasteners
+           python-pyee
+           python-psutil
+           python-fann2
+           python-pyxdg
+           python-websocket-client
+           python-requests
+           python-requests-futures))
+    (home-page "https://github.com/HelloChatterbox/HolmesIV")
+    (synopsis "Mycroft Core, the Mycroft Artificial Intelligence platform")
+    (description "This module provides a hackable open source voice assistant - Mycroft")
+    (license license:asl2.0)))
+
 (define-public python-mycroft-messagebus-client
   (package
     (name "python-mycroft-messagebus-client")
-- 
2.34.0