diff mbox series

[bug#53697] Add wireviz

Message ID 87r18msmdo.fsf@pisemsky.com
State Accepted
Headers show
Series [bug#53697] Add wireviz | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Evgeny Pisemsky Feb. 1, 2022, 2:16 p.m. UTC

Comments

宋文武 Feb. 2, 2022, 3:52 a.m. UTC | #1
Evgeny Pisemsky <evgeny@pisemsky.com> writes:

>>From be078f09ce8d417188e13e097ec4687a27cc5261 Mon Sep 17 00:00:00 2001
> From: Evgeny Pisemsky <evgeny@pisemsky.com>
> Date: Tue, 1 Feb 2022 16:45:45 +0300
> Subject: [PATCH] gnu: Add wireviz.

Pushed to the master, thank you!
diff mbox series

Patch

From be078f09ce8d417188e13e097ec4687a27cc5261 Mon Sep 17 00:00:00 2001
From: Evgeny Pisemsky <evgeny@pisemsky.com>
Date: Tue, 1 Feb 2022 16:45:45 +0300
Subject: [PATCH] gnu: Add wireviz.

* gnu/packages/engineering.scm (wireviz): New variable.
---
 gnu/packages/engineering.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8e4614590b..6e889f6eea 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3270,3 +3271,24 @@  (define-public prusa-slicer
 
     ;; Mark as tunable to take advantage of SIMD code in Eigen and in libigl.
     (properties '((tunable? . #t)))))
+
+(define-public wireviz
+  (package
+    (name "wireviz")
+    (version "0.3.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "wireviz" version))
+              (sha256
+               (base32
+                "1dgnlxxlna2m1fh0ybivw0psym0sa5cqsl72mjl79bwfspnif61h"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-graphviz python-pillow python-pyyaml))
+    (home-page "https://github.com/formatc1702/WireViz")
+    (synopsis "Easily document cables and wiring harnesses")
+    (description
+     "WireViz is a tool for easily documenting cables, wiring harnesses and
+connector pinouts.  It takes plain text, YAML-formatted files as input and
+produces beautiful graphical output thanks to GraphViz.  It handles automatic
+BOM creation and has a lot of extra features.")
+    (license license:gpl3)))

base-commit: 087cdafc9f8ef1d73780ab3e0b4dd340b9e0bce0
-- 
2.34.0