diff mbox series

[bug#53765,v2,16/18] gnu: Add clojure-com-cognitect-aws-s3.

Message ID 87r172cbj3.fsf@reilysiegel.com
State New
Headers show
Series None | expand

Commit Message

Reily Siegel March 16, 2022, 12:44 p.m. UTC
* gnu/packages/clojure.scm (clojure-com-cognitect-aws-s3): New variable.
---
 gnu/packages/clojure.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

M March 26, 2022, 10:03 a.m. UTC | #1
Reily Siegel schreef op wo 16-03-2022 om 13:44 [+0100]:
> +(define-public clojure-com-cognitect-aws-s3
> +  (package
> +    (inherit clojure-com-cognitect-aws-api)
> +    (name "clojure-com-cognitect-aws-s3")
> +    (version "814.2.991.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://repo1.maven.org/maven2/"
> +                                  "com/cognitect/aws/s3/"
> +                                  version "/s3-"
> +                                  version "-sources.jar"))
> +              (sha256
> +               (base32
> +                "0aw3mpddmnjmp45vbmv1l47jn84lgq866fy9mg4wf1x2lqdyhigh"))))

Nevermind my previous comments about ‘All rights reserved’, this seems
to be a leftover of the 1910
(https://en.wikipedia.org/wiki/All_rights_reserved).

However, I still do not have proof that it is actually ASL2.0 license
-- I don't consider pom.xml to be proof by itself, because I often see
packages where the license mentioned in the source files does not match
the license in their equivalent of pom.xml or README.

> +    (native-inputs '())
> +    (propagated-inputs '())
> +    (arguments
> +     '(#:doc-dirs '()
> +       ;; This package has no tests.
> +       #:tests? #f

Alternatively, you can try #:test-dirs '() here.  I don't know what
would be better here.

Greetings,
Maxime.
Reily Siegel March 28, 2022, 9:41 a.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> However, I still do not have proof that it is actually ASL2.0 license
> -- I don't consider pom.xml to be proof by itself, because I often see
> packages where the license mentioned in the source files does not match
> the license in their equivalent of pom.xml or README.

What course of action would you like me to take here? I believe this is
the only indication of the license in the source code, so nothing to
conflict with. I can reach out to Cognitect on slack to confirm that the
license is correct, however given my past interactions I suspect that
the package won't be updated for the benefit of this project.

> Alternatively, you can try #:test-dirs '() here.  I don't know what
> would be better here.

My understanding is that with #:test-dirs '() the clojure build system
still attempts to run a process to run 0 tests, which increases build
time significantly. I believe #:tests? #f is the better choice here.
M March 28, 2022, 11:46 a.m. UTC | #3
Reily Siegel schreef op ma 28-03-2022 om 11:41 [+0200]:
> Maxime Devos <maximedevos@telenet.be> writes:
> 
> > However, I still do not have proof that it is actually ASL2.0 license
> > -- I don't consider pom.xml to be proof by itself, because I often see
> > packages where the license mentioned in the source files does not match
> > the license in their equivalent of pom.xml or README.
> 
> What course of action would you like me to take here? I believe this is
> the only indication of the license in the source code, so nothing to
> conflict with. I can reach out to Cognitect on slack to confirm that the
> license is correct,
> 

That should be sufficient to confirm the licensing terms ...

>  however given my past interactions I suspect that
> the package won't be updated for the benefit of this project.

... however, if that turns out to be the case, then it seems that Guix
cannot include clojure-com-cognitect-aws-s3 as-is, because of 3.2(b) of
the EPL2.0:

  3.2 When the Program is Distributed as Source Code:

      a)[...]
      b) a copy of this Agreement must be included with each copy of the Program.

Perhaps an appropriate snippet would be sufficient, or maybe not.

Rhethorical question: why do people keep forgetting this of kind term (in the
GPL, EPL, Expat or otherwise, even in their own software?)

Do you know where the cognitect slack channels are located?  I've created an
account (for the clojure slack) some time ago, but I don't know where the
cognitect slack is (didn't find it).  Also, do you know if they are also
reachable via some open platform (e-mail, IRC, ...)?

Greetings,
Maxime.
Reily Siegel March 28, 2022, 11:57 a.m. UTC | #4
Maxime Devos <maximedevos@telenet.be> writes:

> Do you know where the cognitect slack channels are located?  I've created an
> account (for the clojure slack) some time ago, but I don't know where the
> cognitect slack is (didn't find it).  Also, do you know if they are also
> reachable via some open platform (e-mail, IRC, ...)?

I was planning on contacting them on #aws on the clojure slack, I am not
aware of any other way to contact Cognitect. AFAIK there is no open
platform for contacting Cognitect, although there is a rarely-used
mailing list and IRC for Clojure itself.
diff mbox series

Patch

diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index ace0a169e8..d2d5bbda48 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -319,6 +319,31 @@  (define-public clojure-com-cognitect-aws-endpoints
     (synopsis "Endpoint data for @code{aws-api}")
     (license license:asl2.0)))
 
+(define-public clojure-com-cognitect-aws-s3
+  (package
+    (inherit clojure-com-cognitect-aws-api)
+    (name "clojure-com-cognitect-aws-s3")
+    (version "814.2.991.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "com/cognitect/aws/s3/"
+                                  version "/s3-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "0aw3mpddmnjmp45vbmv1l47jn84lgq866fy9mg4wf1x2lqdyhigh"))))
+    (native-inputs '())
+    (propagated-inputs '())
+    (arguments
+     '(#:doc-dirs '()
+       ;; This package has no tests.
+       #:tests? #f
+       #:aot-exclude '(#:all)))
+    (synopsis "Supporting files for accessing the S3 API using
+@code{aws-api}")
+    (license license:asl2.0)))
+
 (define-public clojure-com-cognitect-http-client
   (package
     (name "clojure-com-cognitect-http-client")