diff mbox series

bug#56186: [PATCH] gnu: Add python-deepdish.

Message ID 87r132zc1b.fsf@gnu.org
State Accepted
Headers show
Series bug#56186: [PATCH] gnu: Add python-deepdish. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès July 3, 2022, 11:11 a.m. UTC
Hi Antero,

Antero Mejr <antero@mailbox.org> skribis:

> * gnu/packages/python-science.scm (python-deepdish): New variable.

Applied with the changes below (inspired by ‘README.rst’), as per
<https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html>.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 135c6a99ff..747c84d493 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1396,5 +1396,10 @@  (define-public python-deepdish
                              python-tables))
     (home-page "https://github.com/uchicago-cs/deepdish")
     (synopsis "Python library for HDF5 file saving and loading")
-    (description "HDF5 saving/loading and other data science tools.")
+    (description
+     "Deepdish is a Python library to load and save HDF5 files.
+The primary feature of deepdish is its ability to save and load all kinds of
+data as HDF5.  It can save any Python data structure, offering the same ease
+of use as pickling or @code{numpy.save}, but with the language
+interoperability offered by HDF5.")
     (license license:bsd-3)))