diff mbox series

[bug#58179] gnu: Add rofi-switch-browser-tabs.

Message ID 87r0zqvxmh.fsf@ngraves.fr
State New
Headers show
Series [bug#58179] gnu: Add rofi-switch-browser-tabs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Oct. 2, 2022, 7:22 p.m. UTC
* gnu/packages/xdisorg.scm (rofi-switch-browser-tabs): New variable.
---
 gnu/packages/xdisorg.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

--
2.37.3

Sorry for the double send.
In a few words, I forked the project and made it work with minimal
changes without node-chrome-remote-interface. The first commits aren't
useful for this final package anymore, although they are correct and
could still be added if wanted.

--
Best regards,
Nicolas Graves
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9908f29191..e8c201f375 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -56,6 +56,7 @@ 
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Derek Chuank <derekchuank@outlook.com>
 ;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -126,6 +127,7 @@  (define-module (gnu packages xdisorg)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages terminals)
+  #:use-module (gnu packages wget)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages)
@@ -1905,6 +1907,38 @@  (define-public rofi-calc
 natural language input and provide results.")
     (license license:expat)))

+(define-public rofi-switch-browser-tabs
+  (let* ((commit "e1516cc2cb824fb9bdfe45680429e36d6e3789c5")
+         (revision "0"))
+    (package
+      (name "rofi-switch-browser-tabs")
+      (version (git-version "0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/nicolas-graves/rofi-switch-browser-tabs")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "15r3ajf60vgirrlapqf10xlklmwpj4k39sii9ji6djm16anpqwsm"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:phases
+         (modify-phases %standard-phases
+           (add-before 'install 'exe
+             (lambda _ (chmod "switch-browser-tabs" #o555))))
+         #:install-plan
+         (list '("switch-browser-tabs" "bin/"))))
+      (propagated-inputs (list wget jq))
+      (home-page "https://github.com/nicolas-graves/rofi-switch-browser-tabs")
+      (synopsis "Use rofi to switch between browser tabs")
+      (description "This packages provides a simple rofi mode to switch between
+tabs in Chromium-based browsers.  Once installed, just run your browser with
+@code{--remote-debugging-port=9222} and use
+@code{rofi -modi 'switch-tabs:switch-browser-tabs' -show switch-tabs}.")
+      (license license:expat))))
+
 (define-public tint2
   (package
     (name "tint2")