diff mbox series

[bug#60978] gnu: emacs-mu4e-alert: Update to 1.0-0.3c9af8c.

Message ID 87r0voa8ql.fsf@protonmail.com
State New
Headers show
Series [bug#60978] gnu: emacs-mu4e-alert: Update to 1.0-0.3c9af8c. | expand

Commit Message

John Kehayias Jan. 21, 2023, 3:04 a.m. UTC
Hi emacs guixers,

Finally getting around to managing my emacs packages with guix and noticed mu4e-alert is broken with current mu4e versions. The original repo is unmaintained for years and MELPA has switched to an active fork. This patch makes that update for us as well.

Thanks,
John

Comments

Nicolas Goaziou Jan. 25, 2023, 6:02 p.m. UTC | #1
Hello,

John Kehayias via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-mu4e-alert): Update to 1.0-0.3c9af8c.
> [source]: Switch to maintained fork.
> [home-page]: Ditto.
> [synopsis]: Update to match main uses of package.

I re-ordered inputs alphabetically while at it, and applied your patch.

I also used "mode line" spelling (instead of modeline and mode-line).

Thank you.

Regards,
John Kehayias Jan. 25, 2023, 6:17 p.m. UTC | #2
Hi,

On Wed, Jan 25, 2023 at 07:02 PM, Nicolas Goaziou wrote:

> Hello,
>
> John Kehayias via Guix-patches via <guix-patches@gnu.org> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-mu4e-alert): Update to 1.0-0.3c9af8c.
>> [source]: Switch to maintained fork.
>> [home-page]: Ditto.
>> [synopsis]: Update to match main uses of package.
>
> I re-ordered inputs alphabetically while at it, and applied your patch.
>
> I also used "mode line" spelling (instead of modeline and mode-line).
>

Thanks for both! As I mentioned, using Guix now to manage my Emacs packages so I'll likely be looking to do more patches on fixes and updates and appreciate the style notes.

> Thank you.
>
> Regards,
diff mbox series

Patch

From 0dc7bde0fb4e35015b1dccd2827aefb3dd85ab41 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 20 Jan 2023 21:54:32 -0500
Subject: [PATCH] gnu: emacs-mu4e-alert: Update to 1.0-0.3c9af8c.

Original repository is no longer maintained and MELPA has switched to an
active fork, required for compatibility with recent versions of mu4e.  See
<https://github.com/melpa/melpa/pull/7927>.

* gnu/packages/emacs-xyz.scm (emacs-mu4e-alert): Update to 1.0-0.3c9af8c.
[source]: Switch to maintained fork.
[home-page]: Ditto.
[synopsis]: Update to match main uses of package.
---
 gnu/packages/emacs-xyz.scm | 43 ++++++++++++++++++++------------------
 1 file changed, 23 insertions(+), 20 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc85764746..e48143e9cb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -120,6 +120,7 @@ 
 ;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
 ;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
 ;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -15396,28 +15397,30 @@  (define-public emacs-zones
     (license license:gpl3+)))
 
 (define-public emacs-mu4e-alert
-  (package
-    (name "emacs-mu4e-alert")
-    (version "1.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/iqbalansari/mu4e-alert")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1nvsfbfsma59ilf7c3vjngnmx3aapwvvvaafdy5szm5r6lkicqvg"))))
-    (build-system emacs-build-system)
-    (propagated-inputs
-     (list emacs-alert emacs-s emacs-ht mu))
-    (home-page "https://github.com/iqbalansari/mu4e-alert")
-    (synopsis "Desktop notification for mu4e")
-    (description
-     "This package provides desktop notifications for mu4e.
+  (let ((commit "3c9af8c7994df0a1a4f0703552ea3beffb485ace")
+        (revision "0"))
+    (package
+      (name "emacs-mu4e-alert")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/xzz53/mu4e-alert")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "13li5pqqkzj7dwgpnngnk1ff46i100qw9xknlimpy2vf2k5yqv3y"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-alert emacs-s emacs-ht mu))
+      (home-page "https://github.com/xzz53/mu4e-alert")
+      (synopsis "Desktop notifications and modeline display for mu4e")
+      (description
+       "This package provides desktop notifications for mu4e.
 Additionally it can display the number of unread emails in the
 mode-line.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-mu4e-jump-to-list
   (let ((commit "358bba003543b49ffa266e503e54aebd0ebe614b")
-- 
2.39.1