diff mbox series

[bug#61056,v8,2/2] gnu: Add mjwm.

Message ID 87r0uton5l.fsf@163.com
State New
Headers show
Series None | expand

Commit Message

Feng Shu Feb. 13, 2023, 10:49 a.m. UTC
From a21c037b851994b362b2cd8216d4e7aa82056e98 Mon Sep 17 00:00:00 2001
From: Feng Shu <tumashu@163.com>
Date: Sat, 11 Feb 2023 10:55:48 +0800
Subject: [PATCH v8 2/2] gnu: Add mjwm.

* gnu/packages/wm.scm (mjwm): New variable.
---
 gnu/packages/wm.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 14dc3a0988..f719c53127 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -3011,6 +3011,39 @@  such as the Raspberry Pi, though it is perfectly capable of running on modern
 systems.")
     (license license:expat)))
 
+(define-public mjwm
+  (package
+    (name "mjwm")
+    (version "4.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/chiku/mjwm")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0lgfp2xidhvmbj4zqvzz9g8zwbn6mz0pgacc57b43ha523vamsjq"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f   ; no check target
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-subcategory.h
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute* "include/subcategory.h"
+                ;; icon name should be application-other instead of
+                ;; application-others.
+                (("applications-others") "applications-other")))))))
+    (home-page "https://github.com/chiku/mjwm")
+    (synopsis "Create menu for JWM.")
+    (description
+     "MJWM can create JWM's menu from (freedesktop) desktop files and the
+generated file can be include in the rootmenu section of your jwm config
+file.")
+    (license license:gpl2)))
+
 (define-public devour
   (package
     (name "devour")