diff mbox series

[bug#63435] Add vcmi 1.2.1 to games.scm

Message ID 87r0rlm2rn.fsf@wireframe
State New
Headers show
Series [bug#63435] Add vcmi 1.2.1 to games.scm | expand

Commit Message

Vagrant Cascadian May 13, 2023, 1:35 a.m. UTC
On 2023-05-12, Vagrant Cascadian wrote:
> On 2023-05-12, Liliana Marie Prikler wrote:
>> Am Donnerstag, dem 11.05.2023 um 23:17 -0700 schrieb Vagrant Cascadian:
>>> On 2023-05-12, Liliana Marie Prikler wrote:
>>> > Am Donnerstag, dem 11.05.2023 um 16:07 -0700 schrieb Vagrant
>>> > Cascadian:
...
> ...and will send an updated vcmi with this depending on fuzzylite
> shortly.

And the updated vcmi attached.

live well,
  vagrant

Comments

Liliana Marie Prikler May 13, 2023, 6:16 a.m. UTC | #1
Am Freitag, dem 12.05.2023 um 18:35 -0700 schrieb Vagrant Cascadian:

> +     ;; Test suites do not seem well supported upstream and are
> disabled by default.
> +     ;; Pass -DENABLE_TEST to configure to enable.
> +     `(#:configure-flags '("-DFORCE_BUNDLED_FL=OFF")
> +       #:tests? #f))
Readjust your comment, it's misaligned now.  Also, prefer
  (list #:configure-flags #~(list "-DFORCE_BUNDLED_FL=OFF")
        #:tests? #f)
so that people after you won't have to convert it to G-Expressions.

> +           ;; qtbase and qttools @6 not currently buildable but may
> work ok
Prefer ";; XXX: Build currently fails with qtbase-6 and qttools-6".

Cheers
diff mbox series

Patch

From 813871d233700f7d9662aa9108b8dfc1e12e4d91 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sun, 7 May 2023 17:43:33 -0700
Subject: [PATCH 2/2] gnu: Add vcmi 1.2.1.

* gnu/packages/games.scm (vcmi): New variable.
* gnu/packages/patches/vcmi-disable-privacy-breach.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Add patch.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/games.scm                        | 49 +++++++++++++++++++
 .../patches/vcmi-disable-privacy-breach.patch | 21 ++++++++
 3 files changed, 71 insertions(+)
 create mode 100644 gnu/packages/patches/vcmi-disable-privacy-breach.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 89791bea69..ac0137290d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2032,6 +2032,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/vboot-utils-fix-format-load-address.patch	\
   %D%/packages/patches/vboot-utils-fix-tests-show-contents.patch	\
   %D%/packages/patches/vboot-utils-skip-test-workbuf.patch	\
+  %D%/packages/patches/vcmi-disable-privacy-breach.patch	\
   %D%/packages/patches/vinagre-newer-freerdp.patch             \
   %D%/packages/patches/vinagre-newer-rdp-parameters.patch      \
   %D%/packages/patches/virtuoso-ose-remove-pre-built-jar-files.patch	\
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4395476af3..d6a663abc6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -201,6 +201,7 @@  (define-module (gnu packages games)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages squirrel)
   #:use-module (gnu packages swig)
+  #:use-module (gnu packages tbb)
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages terminals)
   #:use-module (gnu packages texinfo)
@@ -11218,6 +11219,54 @@  (define-public fheroes2
 play; it will look for them at @file{~/.local/share/fheroes2} folder.")
     (license license:gpl2)))
 
+(define-public vcmi
+  (package
+    (name "vcmi")
+    (version "1.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/vcmi/vcmi")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0f3fk1fc2wb7f2j4pxz89dzr8zjnrdh435mijia483a3bq59w7pk"))
+              (patches (search-patches "vcmi-disable-privacy-breach.patch"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; Test suites do not seem well supported upstream and are disabled by default.
+     ;; Pass -DENABLE_TEST to configure to enable.
+     `(#:configure-flags '("-DFORCE_BUNDLED_FL=OFF")
+       #:tests? #f))
+    (native-inputs
+     (list boost
+           ffmpeg
+           fuzzylite
+           ;; googletest ; needed for tests, but tests are disabled
+           libxkbcommon
+           luajit
+           minizip
+           pkg-config
+           python
+           ;; qtbase and qttools @6 not currently buildable but may work ok
+           qtbase-5
+           qttools-5
+           sdl2
+           sdl2-mixer
+           sdl2-image
+           sdl2-ttf
+           tbb
+           vulkan-headers
+           zlib))
+    (home-page "https://vcmi.eu/")
+    (synopsis "Turn-based strategy game engine")
+    (description
+     "@code{vcmi} is an implementation of the Heroes of Might and
+Magic III game engine.  It requires assets and game resources to
+play; it will look for them at @file{~/.local/share/vcmi} folder.")
+    (license license:gpl2)))
+
 (define-public apricots
   (package
     (name "apricots")
diff --git a/gnu/packages/patches/vcmi-disable-privacy-breach.patch b/gnu/packages/patches/vcmi-disable-privacy-breach.patch
new file mode 100644
index 0000000000..c03bc66119
--- /dev/null
+++ b/gnu/packages/patches/vcmi-disable-privacy-breach.patch
@@ -0,0 +1,21 @@ 
+Origin: https://salsa.debian.org/games-team/vcmi/-/blob/debian/1.1.0+dfsg-1/debian/patches/disable-privacy-breach
+From: Johannes Schauer <josch@debian.org>
+Subject: do not check remote repositories on startup by default
+Forwarded: not-needed
+
+--- a/config/schemas/settings.json
++++ b/config/schemas/settings.json
+@@ -401,11 +401,11 @@
+ 				},
+ 				"autoCheckRepositories" : {
+ 					"type" : "boolean",
+-					"default" : true
++					"default" : false
+ 				},
+ 				"updateOnStartup" : {
+ 					"type" : "boolean",
+-					"default" : true
++					"default" : false
+ 				},
+ 				"updateConfigUrl" : {
+ 					"type" : "string",
-- 
2.39.2