diff mbox series

[bug#63983] gnu: Add rust-heim-common-0.1.0.

Message ID 87r0qkbl71.fsf@gmail.com
State New
Headers show
Series [bug#63983] gnu: Add rust-heim-common-0.1.0. | expand

Commit Message

Artyom V. Poptsov June 9, 2023, 5:27 p.m. UTC
Hello,

this patch series adds "rust-heim-common"[1] and the related packages.
Thanks,
- avp

References:
1. https://crates.io/crates/heim-common

Comments

Sharlatan Hellseher Feb. 5, 2024, 7:23 p.m. UTC | #1
Hi Efrain,

Which flow do you use for any new Rust packages e.g.
merge to rust-team first or master would be ok?

Thanks,
Oleg
Efraim Flashner Feb. 7, 2024, 3:15 p.m. UTC | #2
On Mon, Feb 05, 2024 at 07:23:20PM +0000, Sharlatan Hellseher wrote:
> Hi Efrain,
> 
> Which flow do you use for any new Rust packages e.g.
> merge to rust-team first or master would be ok?

I normally add them to the rust-team branch first since they often end
up needing to update some of the other packages already there.

It looks like this one slipped through the cracks during the summer.
I'm not exactly sure what to do with these patches, I'd adjust
rust-heim-common to accept any newer rust-mach-0.3, but rust-heim-common
by itself isn't a normal 'leaf package' that we'd add.
diff mbox series

Patch

From d9df27b1fe71860190753fe4d7724f000db98483 Mon Sep 17 00:00:00 2001
Message-Id: <d9df27b1fe71860190753fe4d7724f000db98483.1686331576.git.poptsov.artyom@gmail.com>
In-Reply-To: <151cede3dba70dbcf0e95bbadff0da80dd7a2d07.1686331576.git.poptsov.artyom@gmail.com>
References: <151cede3dba70dbcf0e95bbadff0da80dd7a2d07.1686331576.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Fri, 9 Jun 2023 20:22:37 +0300
Subject: [PATCH 3/3] gnu: Add rust-heim-common-0.1.0.

* gnu/packages/crates-io.scm (rust-heim-common-0.1.0): New variable.
---
 gnu/packages/crates-io.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4faf5cd61d..5c0e93bb3f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -14351,6 +14351,42 @@  (define-public rust-uom-0.30
                (base32
                 "1vg59hnb7hh0p8kjjhgmrsnn3597722lkfdkp481wksq6vk06rg7"))))))
 
+(define-public rust-heim-common-0.1.0
+  (package
+    (name "rust-heim-common")
+    (version "0.1.0-rc.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "heim-common" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0d2qfrhj8j36s6v6j0msq3ck038q5zw4vfsyk9ybx2pqgkjfcryp"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-uom" ,rust-uom-0.30)
+                       ("rust-cfg-if" ,rust-cfg-if-1)
+                       ("rust-core-foundation" ,rust-core-foundation-0.7)
+                       ("rust-futures-core" ,rust-futures-core-0.3)
+                       ("rust-lazy-static" ,rust-lazy-static-1)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-nix" ,rust-nix-0.19)
+                       ("rust-pin-utils" ,rust-pin-utils-0.1)
+                       ("rust-winapi" ,rust-winapi-0.3)
+                       ("rust-mach" ,rust-mach-0.3.2))
+       #:cargo-development-inputs (("rust-version-sync" ,rust-version-sync-0.8)
+                                   ("rust-futures-executor" ,rust-futures-executor-0.3))))
+    (home-page "https://github.com/heim-rs/heim")
+    (synopsis "Async library for system information fetching")
+    (description
+     "@code{heim} is an ongoing attempt to create the best tool for system
+information fetching (for example: CPU, memory, disks or processes stats) in the Rust
+crates ecosystem.
+
+This package contains the common code for other @code{heim} packages and must not be
+used directly.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-crates-index-0.18
   (package
     (name "rust-crates-index")
-- 
2.34.1