diff mbox series

[bug#65439,v2] WAS [bug#65439] [PATCH] maint: Support `guix shell' in Guix's git archive with

Message ID 87r0nbu63p.fsf@gnu.org
State New
Headers show
Series [bug#65439,v2] WAS [bug#65439] [PATCH] maint: Support `guix shell' in Guix's git archive with | expand

Commit Message

Janneke Nieuwenhuizen Sept. 6, 2023, 7:13 a.m. UTC
Janneke Nieuwenhuizen writes:

Hi!

> In the attached patch I share my local hack `maintenance.scm', which
> allows this generalized .envrc

For v2 I removed unnecessary includes.  (Initially `maintenance.scm' was
a bit more interesting.)  Also mention using it implicitly in
Contributing.texi.

[snip .envrc exapmle that runs ./pre-inst-env]

...and while I'm here; I'm using this much simpler .envrc now:

--8<---------------cut here---------------start------------->8---
eval $(guix shell --search-paths)
if test -f doc/dir; then
   export INFOPATH="$PWD/doc${INFOPATH:+:}$INFOPATH"
fi
--8<---------------cut here---------------end--------------->8---

I found that it's better to simply use ./pre-inst-env in the M-x compile
command instead.

Greetings,
Janneke

Comments

Ludovic Courtès Sept. 18, 2023, 8:47 a.m. UTC | #1
Hi,

Janneke Nieuwenhuizen <janneke@gnu.org> skribis:

>>From 7f36f48a4757fc2952b8140b72f1952688d0ac6b Mon Sep 17 00:00:00 2001
> Message-ID: <7f36f48a4757fc2952b8140b72f1952688d0ac6b.1693984077.git.janneke@gnu.org>
> From: Janneke Nieuwenhuizen <janneke@gnu.org>
> Date: Mon, 21 Aug 2023 20:57:12 +0200
> Subject: [PATCH v2] maint: Support `guix shell' in Guix's git archive with
>  manifest.scm.
>
> * manifest.scm: New file.
> * Makefile.am (EXTRA_DIST): Add it.
> * doc/contributing.texi (Building from Git): Mention using it.

Looks great to me!

> +++ b/doc/contributing.texi
> @@ -77,6 +77,12 @@ Building from Git
>  guix shell -D guix --pure
>  @end example
>  
> +or even, from within a Git worktree for Guix

I’d add a colon at the end of the line.  :-)

Thanks,
Ludo’.
Janneke Nieuwenhuizen Sept. 18, 2023, 8:47 a.m. UTC | #2
Janneke Nieuwenhuizen writes:

Hi!

> Janneke Nieuwenhuizen writes:
>
>> In the attached patch I share my local hack `maintenance.scm', which
>> allows this generalized .envrc
>
> For v2 I removed unnecessary includes.  (Initially `maintenance.scm' was
> a bit more interesting.)  Also mention using it implicitly in
> Contributing.texi.
>
> [snip .envrc exapmle that runs ./pre-inst-env]
>
> ...and while I'm here; I'm using this much simpler .envrc now:
>
> eval $(guix shell --search-paths)
> if test -f doc/dir; then
>    export INFOPATH="$PWD/doc${INFOPATH:+:}$INFOPATH"
> fi
>
> I found that it's better to simply use ./pre-inst-env in the M-x compile
> command instead.

It's been four weeks without comment, unless there are any objections
I'll push at the end of the day.

Greetings,
Janneke
Janneke Nieuwenhuizen Sept. 18, 2023, 8:14 p.m. UTC | #3
Ludovic Courtès writes:

Hi,

> Janneke Nieuwenhuizen <janneke@gnu.org> skribis:
>
>>>From 7f36f48a4757fc2952b8140b72f1952688d0ac6b Mon Sep 17 00:00:00 2001
>> Message-ID: <7f36f48a4757fc2952b8140b72f1952688d0ac6b.1693984077.git.janneke@gnu.org>
>> From: Janneke Nieuwenhuizen <janneke@gnu.org>
>> Date: Mon, 21 Aug 2023 20:57:12 +0200
>> Subject: [PATCH v2] maint: Support `guix shell' in Guix's git archive with
>>  manifest.scm.
>>
>> * manifest.scm: New file.
>> * Makefile.am (EXTRA_DIST): Add it.
>> * doc/contributing.texi (Building from Git): Mention using it.
>
> Looks great to me!

Thanks :)

>> +++ b/doc/contributing.texi
>> @@ -77,6 +77,12 @@ Building from Git
>>  guix shell -D guix --pure
>>  @end example
>>  
>> +or even, from within a Git worktree for Guix
>
> I’d add a colon at the end of the line.  :-)

Ah, done.  Pushed to master as 7bf12820f61179900f9d1f753acf91fd33724976

Greetings,
Janneke
diff mbox series

Patch

From 7f36f48a4757fc2952b8140b72f1952688d0ac6b Mon Sep 17 00:00:00 2001
Message-ID: <7f36f48a4757fc2952b8140b72f1952688d0ac6b.1693984077.git.janneke@gnu.org>
From: Janneke Nieuwenhuizen <janneke@gnu.org>
Date: Mon, 21 Aug 2023 20:57:12 +0200
Subject: [PATCH v2] maint: Support `guix shell' in Guix's git archive with
 manifest.scm.

* manifest.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
* doc/contributing.texi (Building from Git): Mention using it.
---
 Makefile.am           |  1 +
 doc/contributing.texi |  6 ++++++
 manifest.scm          | 30 ++++++++++++++++++++++++++++++
 3 files changed, 37 insertions(+)
 create mode 100644 manifest.scm

diff --git a/Makefile.am b/Makefile.am
index 922913355c..8924974e8a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -692,6 +692,7 @@  EXTRA_DIST +=						\
   ROADMAP						\
   TODO							\
   bootstrap						\
+  manifest.scm						\
   build-aux/build-self.scm				\
   build-aux/check-channel-news.scm			\
   build-aux/check-final-inputs-self-contained.scm	\
diff --git a/doc/contributing.texi b/doc/contributing.texi
index fa9238fde8..2ee1e4aa2c 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -77,6 +77,12 @@  Building from Git
 guix shell -D guix --pure
 @end example
 
+or even, from within a Git worktree for Guix
+
+@example
+guix shell --pure
+@end example
+
 @xref{Invoking guix shell}, for more information on that command.
 
 If you are unable to use Guix when building Guix from a checkout, the
diff --git a/manifest.scm b/manifest.scm
new file mode 100644
index 0000000000..bcd94b68c5
--- /dev/null
+++ b/manifest.scm
@@ -0,0 +1,30 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+;; GNU Guix development manifest.  To create development environment, run
+;;
+;;     guix shell
+;;
+;; or something like
+;;
+;;     guix shell --pure git git:send-email openssh
+
+(use-modules (guix profiles)
+             (gnu packages package-management))
+
+(package->development-manifest guix)

base-commit: 6113e0529d61df7425f64e30a6bf77f7cfdfe5a5
-- 
2.41.0