diff mbox series

[bug#68071] gnu: Add python-ast-decompiler.

Message ID 87r0j7cj3f.fsf@troyfigiel.com
State New
Headers show
Series [bug#68071] gnu: Add python-ast-decompiler. | expand

Commit Message

Troy Figiel Dec. 27, 2023, 11:31 p.m. UTC
* gnu/packages/python-xyz.scm (python-ast-decompiler): New variable.

Change-Id: Id0f47c866e72c9f7053da47fdd7aea840a191e62
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 5bd80ccd69047b1777749e24d4adf2c951b5d14b

Comments

Mathieu Othacehe Dec. 28, 2023, 9:25 a.m. UTC | #1
> * gnu/packages/python-xyz.scm (python-ast-decompiler): New variable.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cab44be011..3ad1db7581 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11021,6 +11021,34 @@  (define-public python-pure-eval
 abstract syntax tree (AST) nodes without side effects.")
     (license license:expat)))
 
+(define-public python-ast-decompiler
+  (package
+    (name "python-ast-decompiler")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ast_decompiler" version))
+       (sha256
+        (base32 "0dw3fck4ajilphqw4hdpa8pmqxg3jfk2xkmjnk3kx5pqwl3sbhzg"))
+       ;; We need to manually create an __init__.py file under the tests/
+       ;; directory, since it is not included in the distributed
+       ;; version. (See:
+       ;; https://github.com/JelleZijlstra/ast_decompiler/issues/52).
+       (modules '((guix build utils)))
+       (snippet '(call-with-output-file "tests/__init__.py"
+                   (const #t)))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-flit-core python-pytest))
+    (home-page "https://github.com/JelleZijlstra/ast_decompiler")
+    (synopsis
+     "Decompile an @acronym{AST, Abstract Syntax Tree} to Python code")
+    (description
+     "This library provides functionality to decompile @acronym{AST, Abstract
+Syntax Tree} objects, as generated by the standard library @code{ast} module,
+to Python code.")
+    (license license:asl2.0)))
+
 (define-public python-asttokens
   (package
     (name "python-asttokens")