diff mbox series

[bug#68909] gnu: go-github-com-docker-go-connections: Update to 0.5.0.

Message ID 87r0ht7e59.fsf@troyfigiel.com
State New
Headers show
Series [bug#68909] gnu: go-github-com-docker-go-connections: Update to 0.5.0. | expand

Commit Message

Troy Figiel Feb. 3, 2024, 3:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-docker-go-connections): Update to 0.5.0.
---
 gnu/packages/golang.scm | 45 +++++++++++++++++++----------------------
 1 file changed, 21 insertions(+), 24 deletions(-)


base-commit: 179bb57d2532ee6b81791e078b0f782cbf88cb84

Comments

Hilton Chain Feb. 5, 2024, 7:44 a.m. UTC | #1
Hi Troy,

On Sat, 03 Feb 2024 23:31:47 +0800,
Troy Figiel wrote:
> 
> * gnu/packages/golang.scm (go-github-com-docker-go-connections): Update to 0.5.0.
> ---
>  gnu/packages/golang.scm | 45 +++++++++++++++++++----------------------
>  1 file changed, 21 insertions(+), 24 deletions(-)

Applied as b0d7e4923e0acb3099d4343dceeeb23c5204aeff, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 014ca01602..16074ae0fa 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4776,31 +4776,28 @@  (define-public go-github-com-docker-distribution
       (license license:asl2.0))))
 
 (define-public go-github-com-docker-go-connections
-  (let ((commit "3ede32e2033de7505e6500d6c868c2b9ed9f169d")
-        (revision "0"))
-    (package
-      (name "go-github-com-docker-go-connections")
-      (version (git-version "0.0.0" revision commit))
-      (source
-        (origin
-          (method git-fetch)
-          (uri (git-reference
-                 (url "https://github.com/docker/go-connections")
-                 (commit commit)))
-          (file-name (git-file-name name version))
-          (sha256
-            (base32
-              "0v1pkr8apwmhyzbjfriwdrs1ihlk6pw7izm57r24mf9jdmg3fyb0"))))
-      (build-system go-build-system)
-      (arguments
-        '(#:import-path "github.com/docker/go-connections"))
-      (home-page "https://github.com/docker/go-connections")
-      (synopsis "Networking library for Go")
-      (description
-       "This package provides a library to work with network connections in
-the Go language.  In particular it provides tools to deal with network address
+  (package
+    (name "go-github-com-docker-go-connections")
+    (version "0.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/docker/go-connections")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0svfa9g4xvbn87l5kiww1jkijmci9g5821wjp81xz1rfp13cqrk8"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/docker/go-connections"))
+    (home-page "https://github.com/docker/go-connections")
+    (synopsis "Networking library for Go")
+    (description
+     "This package provides a library to work with network connections in the
+Go language.  In particular it provides tools to deal with network address
 translation (NAT), proxies, sockets, and transport layer security (TLS).")
-      (license license:asl2.0))))
+    (license license:asl2.0)))
 
 (define-public go-github-com-docker-go-units
   (package