diff mbox series

bug#69513: [PATCH v3] services: Add restic-backup service.

Message ID 87r0dq10uq.fsf@gnu.org
State New
Headers show
Series bug#69513: [PATCH v3] services: Add restic-backup service. | expand

Commit Message

Ludovic Courtès May 25, 2024, 1:23 p.m. UTC
Hello,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

> * gnu/services/backup.scm: New file.
> * gnu/local.mk: Add this.
> * doc/guix.texi: Document this.
>
> Change-Id: I9efd5559bb445b484107a7c27c2d0a65ccad1e66

Please consider adding a system test for this: as previously discussed,
we try hard to have tests for every system service.

I’ve applied it with the minor doc changes below.

There might be more work that could be done to ensure the doc is
self-contained.  For instance, I merely guessed that ‘rclone’ needed to
be in the system profile so ‘restic’ would use it, and I cannot tell
what those repository URIs should look like.  Perhaps this can be solved
with a few more words, examples, and/or links to the upstream doc?

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index acf35357a60..d2643cf7fd9 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -41102,10 +41102,13 @@  Miscellaneous Services
 following configuration:
 
 @lisp
+(use-service-modules backup @dots{}) ;for 'restic-backup-service-type'
+(use-package-modules sync @dots{})   ;for 'rclone'
+
 (operating-system
-
-  (packages (list "rclone"))
-
+  ;; @dots{}
+  (packages (append (list rclone)    ;for use by restic
+                    %base-packages))
   (services
     (list
       (service restic-backup-service-type
@@ -41127,7 +41130,8 @@  Miscellaneous Services
 
 Each @code{restic-backup-job} translates to an mcron job which sets the
 @env{RESTIC_PASSWORD} environment variable by reading the first line of
-@code{password-file} and runs @command{restic backup}.
+@code{password-file} and runs @command{restic backup}, creating backups
+using rclone of all the files listed in the @code{files} field.
 
 The @code{restic-backup-service-type} installs as well @code{restic-guix}
 to the system profile, a @code{restic} utility wrapper that allows for easier