[bug#72387] Fix reproducible build for readymedia

Message ID 87r0batqek.fsf@wireframe
State New
Headers
Series [bug#72387] Fix reproducible build for readymedia |

Commit Message

Vagrant Cascadian July 30, 2024, 11:24 p.m. UTC
  The attached patch should fix build reproducibility issues of
"readymedia" by avoiding embedding the running kernel version of the
build machine.

This was one of the examples used in the Reproducible Builds patch
session On July 11th!

  https://libreplanet.org/wiki/Group:Guix/PatchReviewSessions2024

live well,
  vagrant
  

Comments

Z572 Aug. 1, 2024, 3:56 p.m. UTC | #1
Vagrant Cascadian <vagrant@reproducible-builds.org> writes:

> The attached patch should fix build reproducibility issues of
> "readymedia" by avoiding embedding the running kernel version of the
> build machine.
>
> This was one of the examples used in the Reproducible Builds patch
> session On July 11th!
>
>   https://libreplanet.org/wiki/Group:Guix/PatchReviewSessions2024
>
> live well,
>   vagrant
>
> [2. text/x-diff; 0001-gnu-readymedia-Fix-reproducible-build.patch]
> From e40dc4bc9633a44fc10ea49007618a41fa598d99 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
> Date: Wed, 3 Jul 2024 14:00:34 -0700
> Subject: [PATCH] gnu: readymedia: Fix reproducible build.
>
> * gnu/packages/upnp.scm (readymedia)[configure-flags]: Avoid embedding kernel
> version.
> ---
>  gnu/packages/upnp.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
> index aab68a6414..5514b3632b 100644
> --- a/gnu/packages/upnp.scm
> +++ b/gnu/packages/upnp.scm
> @@ -150,7 +150,8 @@ (define-public readymedia
>          (base32 "1al04jx72bxwqch1nv9lx536mb6pvj7pgnqzy6lm32q6xa114yr2"))))
>      (build-system gnu-build-system)
>      (arguments
> -     `(#:configure-flags '("--with-os-name=Linux")      ; uname -s
> +     `(#:configure-flags '("--with-os-name=Linux" ; uname -s
> +                           "--with-os-version=") ; uname -r
>         #:phases
>         (modify-phases %standard-phases
>           (add-after 'unpack 'patch-source
>
> base-commit: 2aa0127d4e3d2363c04caab88137b070b6cf1318

Thanks, push, close.
  

Patch

From e40dc4bc9633a44fc10ea49007618a41fa598d99 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Wed, 3 Jul 2024 14:00:34 -0700
Subject: [PATCH] gnu: readymedia: Fix reproducible build.

* gnu/packages/upnp.scm (readymedia)[configure-flags]: Avoid embedding kernel
version.
---
 gnu/packages/upnp.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index aab68a6414..5514b3632b 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -150,7 +150,8 @@  (define-public readymedia
         (base32 "1al04jx72bxwqch1nv9lx536mb6pvj7pgnqzy6lm32q6xa114yr2"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags '("--with-os-name=Linux")      ; uname -s
+     `(#:configure-flags '("--with-os-name=Linux" ; uname -s
+                           "--with-os-version=") ; uname -r
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-source

base-commit: 2aa0127d4e3d2363c04caab88137b070b6cf1318
-- 
2.39.2