[bug#75389,1/2] gnu: hunspell: Add Swiss German dictionary.

Message ID 87r05hrr4p.fsf@erlikon.ch
State New
Headers
Series Add Austrian and Swiss hunspell dictionaries. |

Commit Message

Gabriel Wicki Jan. 5, 2025, 7:25 p.m. UTC
  * gnu/packages/hunspell.scm(hunspell-dict-de-ch): New variable.

Change-Id: Ib868e7efaa92e536229d45098ffd8f38a9441b83
---
 gnu/packages/hunspell.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
  

Patch

diff --git a/gnu/packages/hunspell.scm b/gnu/packages/hunspell.scm
index eed10b16bb..73092d6839 100644
--- a/gnu/packages/hunspell.scm
+++ b/gnu/packages/hunspell.scm
@@ -219,6 +219,39 @@  (define-public hunspell-dict-de
     (home-page "https://www.j3e.de/ispell/igerman98/")
     (license (list license:gpl2 license:gpl3))))
 
+(define-public hunspell-dict-de-ch
+  (package
+    (name "hunspell-dict-de-ch")
+    (version "20161207")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.j3e.de/ispell/igerman98/dict/"
+                           "igerman98-" version ".tar.bz2"))
+       (sha256
+        (base32 "1a3055hp2bc4q4nlg3gmg0147p3a1zlfnc65xiv2v9pyql1nya8p"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags '("hunspell/de_CH.dic")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (replace 'install              ;no install target
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (share (string-append out "/share/hunspell/")))
+               (install-file "hunspell/de_CH.aff" share)
+               (install-file "hunspell/de_CH.dic" share)
+               #t))))
+       #:tests? #f))        ; no tests
+    (native-inputs
+     (list hunspell ispell perl))
+    (synopsis "Hunspell dictionary for Swiss German (de_CH)")
+    (description "This package provides a dictionary for the Hunspell
+spell-checking library.")
+    (home-page "https://www.j3e.de/ispell/igerman98/")
+    (license (list license:gpl2 license:gpl3))))
+
 (define-public hunspell-dict-hu
   (let ((revision "2")
         (major+minor "1.7"))