[bug#34365] gnu: Add python-daemon.

Message ID 87pns37iwj.fsf@ponder
State Accepted
Headers show
Series [bug#34365] gnu: Add python-daemon. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Vagrant Cascadian Feb. 7, 2019, 2:49 p.m. UTC
On 2019-02-07, Ricardo Wurmus wrote:
> Vagrant Cascadian <vagrant@debian.org> writes:
>
>>> Before pushing this I’ll add a final #T to this phase.  (In the past #F
>>> would indicate failure, but that’s on longer the case.  “substitute*”
>>> annoyingly returns an unspecified value.)
...
>>>> +    (license (list license:asl2.0 license:gpl3+))))
>>>
>>> What does this list mean?
...
>> Apparently only setup.py is gpl3+, everything else is apache 2.0
>> licensed. That was my quick look at the code itself, and basically
>> confirmed by:
>>
>>   https://sources.debian.org/src/python-daemon/2.2.3-1/debian/copyright/
>
> Excellent.  This can be added as a short comment above the license
> field.

Ok, the attached patch should address the above two issues and removed
the needless python-setuptools and python-docutils propagated inputs
mentioned earlier.

live well,
  vagrant

Comments

Danny Milosavljevic Feb. 11, 2019, 9:48 a.m. UTC | #1
Hi Vagrant,

thanks!  I've applied this to guix master.

I've also reported the test failure upstream as https://pagure.io/python-daemon/issue/28

Patch

From e22c1ac09a3db62eca7db12d4322672ab18c2ffc Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Thu, 7 Feb 2019 01:27:41 -0800
Subject: [PATCH] gnu: Add python-daemon.

* gnu/packages/python-xyz.scm (python-daemon): New variable.
---
 gnu/packages/python-xyz.scm | 51 +++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d2b348942..cf293c004 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2188,6 +2188,57 @@  logging and tracing of the execution.")
 (define-public python2-joblib
   (package-with-python2 python-joblib))
 
+(define-public python-daemon
+  (package
+    (name "python-daemon")
+    (version "2.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-daemon" version))
+       (sha256
+        (base32
+         "09fcjdjzk9ywmpnrj62iyxqgcygzdafsz41qlrk2dknzbagcmzmg"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'disable-tests
+           (lambda _
+             ;; FIXME: Determine why test fails
+             (substitute* "test/test_daemon.py"
+               (("test_detaches_process_context")
+                "skip_test_detaches_process_context"))
+             #t)))))
+    (propagated-inputs
+     `(("python-lockfile" ,python-lockfile)))
+    (native-inputs
+     `(("python-unittest2" ,python-unittest2)
+       ("python-testtools" ,python-testtools)
+       ("python-testscenarios" ,python-testscenarios)
+       ("python-mock" ,python-mock)
+       ("python-docutils" ,python-docutils)))
+    (home-page "https://pagure.io/python-daemon/")
+    (synopsis "Python library for making a Unix daemon process")
+    (description "Python-daemon is a library that assists a Python program to
+turn itself into a well-behaved Unix daemon process, as specified in PEP 3143.
+
+This library provides a @code{DaemonContext} class that manages the following
+important tasks for becoming a daemon process:
+@enumerate
+@item Detach the process into its own process group.
+@item Set process environment appropriate for running inside a chroot.
+@item Renounce suid and sgid privileges.
+@item Close all open file descriptors.
+@item Change the working directory, uid, gid, and umask.
+@item Set appropriate signal handlers.
+@item Open new file descriptors for stdin, stdout, and stderr.
+@item Manage a specified PID lock file.
+@item Register cleanup functions for at-exit processing.
+@end enumerate")
+    ;; Only setup.py is gpl3+, everything else is apache 2.0 licensed.
+    (license (list license:asl2.0 license:gpl3+))))
+
 (define-public python-docutils
   (package
     (name "python-docutils")
-- 
2.20.1