diff mbox series

[bug#40258] gnu: Add emacs-flycheck-elm.

Message ID 87pncw43rc.fsf@asu.edu
State Accepted
Headers show
Series [bug#40258] gnu: Add emacs-flycheck-elm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

John Soo March 28, 2020, 8:35 p.m. UTC
Hi Guix,

I forgot my patch was applied on some other work.

This cherry-picks it on to master.

Thanks,

John

Comments

Nicolas Goaziou March 30, 2020, 1:10 p.m. UTC | #1
Hello,

John Soo <jsoo1@asu.edu> writes:

> Subject: [PATCH] gnu: Add emacs-flycheck-elm.
>
> * gnu/packages/emacs-xyz.scm (emacs-flycheck-elm): New variable.

Thank you.

> +;;; Copyright © 2020 John Soo <jsoo1@asu.edu>

You can remove this line, already applied in a previous patch.


> +(define-public emacs-flycheck-elm
> +  (package
> +    (name "emacs-flycheck-elm")
> +    (version "debd0af")

This is not a proper version string (not monotonic). You should bind
`commit' to "debd0af563cb6c2944367a691c7fa3021d9378c1" and `revision' to
"O" at the top of your package definition, and use

  (version (git-version "0" revision commit))

> +         (commit version)))

In the case above, this should be:

  (commit commit)

> +    (inputs
> +     `(("emacs-flycheck" ,emacs-flycheck)
> +       ("emacs-let-alist" ,emacs-let-alist)
> +       ("emacs-seq" ,emacs-seq)))

I don't think you need "emacs-seq" since we build packages with Emacs
26.3, which includes "seq.el" already.

> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/bsermons/flycheck-elm")
> +    (synopsis "Flycheck support for the elm language")
> +    (description "Flycheck support for the elm language.")

Nitpick: I would use Elm.

The description needs to be a full sentence.

> +    (license license:gpl2+)))

All source code files are GPL3+, so this probably makes the project
GPL3+ licensed. LICENSE file is GPL2 (not 2+), but I would trust source
code in this case.

You may want to tell upstream about this discrepancy.

Could you send an updated patch?

Regards,
diff mbox series

Patch

>From 64341a1ae6717f3e178d56197cceb5022815992b Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:57:31 -0700
Subject: [PATCH] gnu: Add emacs-flycheck-elm.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-elm): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86033fd200..f56cc16970 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21774,3 +21775,28 @@  enables modal editing and composition of commands, too.  It combines ideas of
 other Editors like Vim or Kakoune and tries to align them with regular Emacs
 conventions.")
     (license license:gpl3+)))
+
+(define-public emacs-flycheck-elm
+  (package
+    (name "emacs-flycheck-elm")
+    (version "debd0af")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/bsermons/flycheck-elm")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1vl0lss2n50pz5wscqj6vhjwb4hbg8xx2chh5vafsrnn0a3fryrd"))))
+    (inputs
+     `(("emacs-flycheck" ,emacs-flycheck)
+       ("emacs-let-alist" ,emacs-let-alist)
+       ("emacs-seq" ,emacs-seq)))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/bsermons/flycheck-elm")
+    (synopsis "Flycheck support for the elm language")
+    (description "Flycheck support for the elm language.")
+    (license license:gpl2+)))
-- 
2.26.0