diff mbox series

[bug#40511,REDO,1,7/10] gnu: Add python-trustme.

Message ID 87pnbrs6p6.fsf@dustycloud.org
State Work in progress
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber April 28, 2020, 8:20 p.m. UTC

diff mbox series

Patch

From 7ee9609dbe202a7fa2199c659ef8469415b283b2 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 28 Apr 2020 15:22:18 -0400
Subject: [PATCH 07/10] gnu: Add python-trustme.

* gnu/packages/python-xyz.scm (python-trustme): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 70ff012fb6..a6d86cbc50 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19778,3 +19778,26 @@  and watchdog.")
     (description
      "Use the Python requests library to talk HTTP via a UNIX domain socket.")
     (license license:asl2.0)))
+
+(define-public python-trustme
+  (package
+    (name "python-trustme")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trustme" version))
+       (sha256
+        (base32
+         "0v3vr5z6apnfmklf07m45kv5kaqvm6hxrkaqywch57bjd2siiywx"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-cryptography" ,python-cryptography)
+       ("python-idna" ,python-idna)))
+    (home-page
+     "https://github.com/python-trio/trustme")
+    (synopsis
+     "Fake certificate authority for unit tests")
+    (description
+     "Provides fake a fake TLS certificate authority for Python unit tests.")
+    (license license:asl2.0)))
-- 
2.26.0