diff mbox series

[bug#44425,2/3] gnu: Add ghc-network-multicast.

Message ID 87pn4u853b.fsf@dustycloud.org
State Accepted
Headers show
Series None | expand

Commit Message

Christine Lemmer-Webber Nov. 3, 2020, 10:10 p.m. UTC

Comments

Christine Lemmer-Webber Nov. 3, 2020, 10:19 p.m. UTC | #1
Just as the subject says (about the previous one being wrong) :)

I should figure out how to do the automated patchseries thing...
Christine Lemmer-Webber Nov. 3, 2020, 11:33 p.m. UTC | #2
Sorry, closing this.  Apparently I can't email today. :\
diff mbox series

Patch

From db08ffd29e48961c1192be623b13ff272c87e5c5 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 3 Nov 2020 17:04:09 -0500
Subject: [PATCH 3/3] git-annex: Enable pairing and assistant features.

* gnu/packages/haskell-apps.scm (git-annex): Add appropriate
  dependencies and adjust flags to enable "assistant" and "pairing"
  features.
---
 gnu/packages/haskell-apps.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 1de8b040f1..da1bd2128c 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -350,7 +350,7 @@  to @code{cabal repl}).")
     (build-system haskell-build-system)
     (arguments
      `(#:configure-flags
-       '("--flags=-Android -Assistant -Pairing -Webapp")
+       '("--flags=-Android -Webapp")
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'patch-shell-for-tests
@@ -457,6 +457,7 @@  to @code{cabal repl}).")
        ("ghc-feed" ,ghc-feed)
        ("ghc-filepath-bytestring" ,ghc-filepath-bytestring)
        ("ghc-free" ,ghc-free)
+       ("ghc-hinotify" ,ghc-hinotify)
        ("ghc-hslogger" ,ghc-hslogger)
        ("ghc-http-client" ,ghc-http-client)
        ("ghc-http-conduit" ,ghc-http-conduit)
@@ -466,7 +467,10 @@  to @code{cabal repl}).")
        ("ghc-memory" ,ghc-memory)
        ("ghc-monad-control" ,ghc-monad-control)
        ("ghc-monad-logger" ,ghc-monad-logger)
+       ("ghc-mountpoints" ,ghc-mountpoints)
        ("ghc-network" ,ghc-network)
+       ("ghc-network-info" ,ghc-network-info)
+       ("ghc-network-multicast" ,ghc-network-multicast)
        ("ghc-old-locale" ,ghc-old-locale)
        ("ghc-optparse-applicative" ,ghc-optparse-applicative)
        ("ghc-persistent" ,ghc-persistent)
-- 
2.29.1