diff mbox series

[bug#45861] Add embree and update Blender

Message ID 87pn2761bn.fsf@dustycloud.org
State Accepted
Headers show
Series [bug#45861] Add embree and update Blender | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Christine Lemmer-Webber Jan. 14, 2021, 2:27 p.m. UTC
Two patches attached.  Embree seems necessary for the newer Blender.

(Sadly newer Blender also still has graphics crashes on my GPU.  Wah!
Well, enjoy to those of you who can.)

Comments

Leo Famulari Jan. 16, 2021, 8:42 p.m. UTC | #1
On Thu, Jan 14, 2021 at 09:27:24AM -0500, Christopher Lemmer Webber wrote:
> Two patches attached.  Embree seems necessary for the newer Blender.
> 
> (Sadly newer Blender also still has graphics crashes on my GPU.  Wah!
> Well, enjoy to those of you who can.)

Thanks! Pushed as 2a333f2535a65bfa3607ef50591e9f5dbc6970d1
diff mbox series

Patch

From ce00650a374bd4a4bb866e5492dd2483222323f8 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Wed, 13 Jan 2021 14:46:23 -0500
Subject: [PATCH 2/2] gnu: blender: Update to 2.91.0.

* gnu/packages/graphics.scm (blender): Update to 2.91.0 and add embree as a
  dependency.
---
 gnu/packages/graphics.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 09cf47b66a..01f0671ddc 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -461,14 +461,14 @@  applications.")
 (define-public blender
   (package
     (name "blender")
-    (version "2.83.9")
+    (version "2.91.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.blender.org/source/"
                                   "blender-" version ".tar.xz"))
               (sha256
                (base32
-                "106w9vi6z0gi2nbr73g8pm40w3wn7dkjcibzvvzbc786yrnzvkhb"))))
+                "0x396lgmk0dq9115yrc36s8zwxzmjr490sr5n2y6w27y17yllyjm"))))
     (build-system cmake-build-system)
     (arguments
       (let ((python-version (version-major+minor (package-version python))))
@@ -540,7 +540,8 @@  applications.")
        ("python" ,python)
        ("python-numpy" ,python-numpy)
        ("tbb" ,tbb)
-       ("zlib" ,zlib)))
+       ("zlib" ,zlib)
+       ("embree" ,embree)))
     (home-page "https://blender.org/")
     (synopsis "3D graphics creation suite")
     (description
-- 
2.30.0