[bug#53879] gnu: Add emacs-everywhere.
Commit Message
Comments
Hello,
Jai Vetrivelan <jaivetrivelan@gmail.com> writes:
> Subject: [PATCH] gnu: Add emacs-everywhere.
Thanks. Some comments follow.
> +(define-public emacs-everywhere
> + ;; No upstream release. Extract version from main file.
> + (let ((revision "0") (version "0.0.1")
Nitpick: binding should go to separate lines. However, in this case,
I suggest to move version string right in the "version" field. It will
make life of the updater scripts easier.
> + (propagated-inputs
> + (list xclip xdotool xprop xwininfo))
Could you turn those into regular inputs, and patch calls in the
library? Ideally, upstream should turn the location of these executables
into a defcustom. You may want to suggest it to them.
Regards,
On 2022-02-08, 18:29 +0100, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>> + (propagated-inputs
>> + (list xclip xdotool xprop xwininfo))
>
> Could you turn those into regular inputs, and patch calls in the
> library? Ideally, upstream should turn the location of these
> executables into a defcustom. You may want to suggest it to them.
Could you please point out any package that does this, so that I could
better understand what you're talking about.
Thanks!
Hello,
Jai Vetrivelan <jaivetrivelan@gmail.com> writes:
>> Could you turn those into regular inputs, and patch calls in the
>> library? Ideally, upstream should turn the location of these
>> executables into a defcustom. You may want to suggest it to them.
>
> Could you please point out any package that does this, so that I could
> better understand what you're talking about.
Certainly. See, for example, `patch-exec-paths' phase in emacs-theme-magic.
Regards,
From f8f503e5aea4515340d9f7b86ad96ceb4bb71502 Mon Sep 17 00:00:00 2001
From: Jai Vetrivelan <jaivetrivelan@gmail.com>
Date: Tue, 8 Feb 2022 20:44:05 +0530
Subject: [PATCH] gnu: Add emacs-everywhere.
* gnu/packages/emacs-xyz.scm (emacs-everywhere): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -26279,6 +26279,32 @@ (define-public emacs-evil-tmux-navigator
Emacs windows and tmux panes.")
(license license:expat)))
+(define-public emacs-everywhere
+ ;; No upstream release. Extract version from main file.
+ (let ((revision "0") (version "0.0.1")
+ (commit "ace53396a66ed4b753f42c04a5a0db2bcd770423"))
+ (package
+ (name "emacs-everywhere")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tecosaur/emacs-everywhere")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0p55shxvqm1713af33mfglny7rpi31d42wvgwylcsfy4jvnsq8bb"))))
+ (propagated-inputs
+ (list xclip xdotool xprop xwininfo))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tecosaur/emacs-everywhere")
+ (synopsis "System-wide popup Emacs windows for quick edits")
+ (description "@code{emacs-everywhere} launches a new Emacs frame, and the
+contents of the buffer are pasted into the previously focused application on
+deletion of the frame.")
+ (license license:gpl3+))))
+
(define-public emacs-xclip
(package
(name "emacs-xclip")
base-commit: 35d56676db0988aad6d1a5b52dc4efef578885f2
--
2.34.0