diff mbox series

[bug#59287] Adding svtplay-dl

Message ID 87pmdoexn4.fsf@tsyesika.se
State New
Headers show
Series [bug#59287] Adding svtplay-dl | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Jessica Tallon Nov. 15, 2022, 9:02 p.m. UTC
Hello,

I've packaged svtplay-dl, a program to download content from the Swedish
TV broadcaster among others.
diff mbox series

Patch

From e38e635f459aa7740459b40943af88b6ee2624fd Mon Sep 17 00:00:00 2001
Message-Id: <e38e635f459aa7740459b40943af88b6ee2624fd.1668546132.git.tsyesika@tsyesika.se>
From: Jessica Tallon <tsyesika@tsyesika.se>
Date: Tue, 15 Nov 2022 22:00:01 +0100
Subject: [PATCH] Add svtplay-dl

* gnu/packages/video.scm (svtplay-dl): New variable.
---
 gnu/packages/video.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c8f3c6f8a5..aabbe1fc8b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5605,3 +5605,27 @@  (define-public video-contact-sheet
 for details on how to change this.")
    (home-page "http://p.outlyer.net/vcs/")
    (license license:lgpl2.1+)))
+
+(define-public svtplay-dl
+  (package
+    (name "svtplay-dl")
+    (version "4.14")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/spaam/svtplay-dl")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1wdrdszalvhv80m5jizbvjz4jc08acmbpxcsslyfb5cwh842in8m"))))
+    (build-system python-build-system)
+    (inputs (list ffmpeg python-pyaml python-requests python-pysocks
+                  python-cryptography))
+    (home-page "https://svtplay-dl.se/")
+    (synopsis "Download or stream SVT Play's (and others) TV programmes")
+    (description
+     "@code{svtplay-dl} allows downloading TV programmes from various swedish
+broadcasters including SVT Play, Sveriges Radio, TV4 Play, among with many
+others.")
+    (license license:expat)))
-- 
2.38.1