diff mbox series

[bug#59930] gnu: Add emacs-islisp-mode

Message ID 87pmcse1fo.fsf@kleptop.mail-host-address-is-not-set
State New
Headers show
Series [bug#59930] gnu: Add emacs-islisp-mode | expand

Commit Message

Joeke de Graaf Dec. 9, 2022, 9:01 p.m. UTC
This patch adds emacs-islisp-mode to emacs-xyz.scm

Best regards,

Joeke de Graaf

Comments

Nicolas Goaziou Dec. 14, 2022, 4:36 p.m. UTC | #1
Hello,

Joeke de Graaf <joeke@posteo.net> writes:

> This patch adds emacs-islisp-mode to emacs-xyz.scm

Thank you. Some comments follow.

> +    (build-system emacs-build-system)
> +    (arguments
> +     (list #:phases #~(modify-phases %standard-phases
> +			;; Install Emacs Lisp files from the "advance"
> +			;; and "implementations" directories
> +                        (add-after 'install 'install-additional-directories
> +                          (lambda _
> +                            (let ((site-lisp-dir (string-append #$output
> +                                                  "/share/emacs/site-lisp/islisp-mode-"
> +                                                  #$version)))

You can use (elpa-directory #$output) instead of (string-append ...)

> +                              (map (lambda (dir)
> +                                     (with-directory-excursion dir
> +                                       (for-each (lambda (file)
> +                                                   (install-file file
> +                                                    site-lisp-dir))
> +                                                 (find-files "." "\\.el$"))))
> +                                   '("advance" "implementations"))))))))

You can use for-each instead of map since you don't need the return
value. Moreover, `copy-recursively' is probably shorter.

However, this will catch neither the ".el" file nor the ".lsp" file in
"implementations/easy-islisp" directory. What should we do about the
latter ?

You also need to add `eisl' as an input, and patch "easy-islisp.el"
accordingly (see `easy-islisp-executable').

Could you send an updated patch?

Regards,
diff mbox series

Patch

From fc661dcc856de74034964fd0734cabce5cef4eaa Mon Sep 17 00:00:00 2001
From: Joeke <joeke@posteo.net>
Date: Fri, 9 Dec 2022 21:52:40 +0100
Subject: [PATCH] gnu: Add emacs-islisp-mode

---
 gnu/packages/emacs-xyz.scm | 41 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0d11c59b48..4170787ca1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -118,6 +118,7 @@ 
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
+;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -13125,6 +13126,46 @@  (define-public emacs-helm-make
 target will call @code{compile} on it.")
       (license license:gpl3+))))
 
+(define-public emacs-islisp-mode
+  (package
+    (name "emacs-islisp-mode")
+    (version "0.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/sasanidas/islisp-mode")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1s6alrv1hfi1plj5lh826j0h71xvm2v092kglj3yvy34g73dgrna"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+			;; Install Emacs Lisp files from the "advance"
+			;; and "implementations" directories
+                        (add-after 'install 'install-additional-directories
+                          (lambda _
+                            (let ((site-lisp-dir (string-append #$output
+                                                  "/share/emacs/site-lisp/islisp-mode-"
+                                                  #$version)))
+                              (map (lambda (dir)
+                                     (with-directory-excursion dir
+                                       (for-each (lambda (file)
+                                                   (install-file file
+                                                    site-lisp-dir))
+                                                 (find-files "." "\\.el$"))))
+                                   '("advance" "implementations"))))))))
+    (home-page "https://gitlab.com/sasanidas/islisp-mode")
+    (synopsis "ISLisp support for Emacs")
+    (description
+     "This package provides support for programming with ISLisp in
+Emacs.  It features a major mode with syntax highlighting, symbol autocompletion
+and documentation search, among other features.  It also includes an inferior
+mode with REPL integration.  Currently it only supports the Easy ISLisp (eisl)
+implementation.")
+    (license license:gpl3+)))
+
 (define-public emacs-cider
   (package
     (name "emacs-cider")
-- 
2.37.2