diff mbox series

[bug#60293] gnu: Add sbcl-stumpwm-battery-portable

Message ID 87pmc9qu43.fsf@guix.mail-host-address-is-not-set
State New
Headers show
Series [bug#60293] gnu: Add sbcl-stumpwm-battery-portable | expand

Commit Message

Trevor Richards Dec. 24, 2022, 4:54 a.m. UTC
---
 gnu/packages/wm.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Guillaume Le Vaillant Jan. 2, 2023, 2:59 p.m. UTC | #1
Patch pushed as 8aa104752cb6a61f2ac689c31ac627ccab32f7fe with a few
modifications.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 18fe606c7b..d13863d64d 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2358,6 +2358,24 @@  (define-public sbcl-stumpwm-notify
 by default.")
     (license license:gpl3+)))
 
+(define-public sbcl-stumpwm-battery-portable
+  (package
+    (inherit stumpwm-contrib)
+    (name "sbcl-stumpwm-battery-portable")
+    (build-system asdf-build-system/sbcl)
+    (inputs (list
+             cl-ppcre
+             (list stumpwm "lib")))
+    (arguments
+     '(#:asd-systems '("battery-portable")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _ (chdir "modeline/battery-portable"))))))
+    (synopsis "A battery level indicator for the mode-line")
+    (description "This module provides a battery-level indicator for the
+modeline.  It can be displayed in the mode-line with %B.")))
+
 (define-public lemonbar
   (package
     (name "lemonbar")