diff mbox series

[bug#63409] gnu: cagebreak: Update to 2.1.2.

Message ID 87pm78ylai.fsf@163.com
State New
Headers show
Series [bug#63409] gnu: cagebreak: Update to 2.1.2. | expand

Commit Message

Feng Shu May 10, 2023, 2:25 a.m. UTC
From 4ac961551d03a84e570d7eedb51101dfdd9e49ce Mon Sep 17 00:00:00 2001
Date: Tue, 9 May 2023 15:37:49 +0800

* gnu/packages/wm.scm (cagebreak): Update to 2.1.2.
Explicitly disable tests and substitute "/usr/share/".
---
 gnu/packages/wm.scm | 23 ++++++++++++++---------
 1 file changed, 14 insertions(+), 9 deletions(-)

Comments

Ludovic Courtès May 20, 2023, 11:16 p.m. UTC | #1
Feng Shu <tumashu@163.com> skribis:

>>From 4ac961551d03a84e570d7eedb51101dfdd9e49ce Mon Sep 17 00:00:00 2001
> Date: Tue, 9 May 2023 15:37:49 +0800
>
> * gnu/packages/wm.scm (cagebreak): Update to 2.1.2.
> Explicitly disable tests and substitute "/usr/share/".

Applied as well!
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index fe732e572e..28e4c04814 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2750,7 +2750,7 @@  shows a notification for the user on the screen.")
 (define-public cagebreak
   (package
     (name "cagebreak")
-    (version "2.0.1")
+    (version "2.1.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2759,16 +2759,21 @@  shows a notification for the user on the screen.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0fxfmxl7p63l07lqb83q5lx16hm0rixcidghx00gp08x2yrgr4x9"))))
+                "09ky8wili3ym8qi4dasckdcdcvn4g6ak08dg0yccnwmnlwxiyps6"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-Dxwayland=true")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-data-dir
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "meson.build"
-               (("/etc/") (string-append (assoc-ref outputs "out") "/etc"))))))))
+     (list
+      #:configure-flags #~(list "-Dxwayland=true")
+      ;; XXX: Running cagebreak tests need more tools, such as: clang-format,
+      ;; shellcheck, git, gnupg ...
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-data-dir
+            (lambda _
+              (substitute* '("cagebreak.c" "meson.build")
+                (("/etc/") (string-append #$output "/etc/"))
+                (("/usr/share/") (string-append #$output "/usr/share/"))))))))
     (native-inputs (list pandoc pkg-config))
     (inputs (list libevdev pango wlroots))
     (home-page "https://github.com/project-repo/cagebreak")