diff mbox series

[bug#69113] gnu: go-github-com-schollz-progressbar-v3: Remove examples.

Message ID 87plx0asgg.fsf@troyfigiel.com
State New
Headers show
Series [bug#69113] gnu: go-github-com-schollz-progressbar-v3: Remove examples. | expand

Commit Message

Troy Figiel Feb. 13, 2024, 7:47 p.m. UTC
* gnu/packages/golang.scm (go-github-com-schollz-progressbar-v3): Remove
examples.
[arguments]<#:phases>: Add remove-examples phase.
---
 gnu/packages/golang.scm | 4 ++++
 1 file changed, 4 insertions(+)


base-commit: ac470c516e19f194228edf9e348bdbc7fc10f97a

Comments

Sharlatan Hellseher Feb. 19, 2024, 11:53 p.m. UTC | #1
Hi,

Pushed as d6cc85825feedba6a15717cc5e835b79aec5cb12 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 25e9715c79..c317e40979 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10227,6 +10227,10 @@  (define-public go-github-com-schollz-progressbar-v3
      (list #:import-path "github.com/schollz/progressbar/v3"
            #:phases
            #~(modify-phases %standard-phases
+               (add-after 'unpack 'remove-examples
+                 (lambda* (#:key import-path #:allow-other-keys)
+                   (delete-file-recursively
+                    (string-append "src/" import-path "/examples"))))
                (replace 'check
                  (lambda* (#:key tests? import-path #:allow-other-keys)
                    (when tests?