diff mbox series

[bug#73532] gnupg: Also look in .guix-home for pinentry

Message ID 87plonftyv.fsf@denver.mail-host-address-is-not-set
State New
Headers show
Series [bug#73532] gnupg: Also look in .guix-home for pinentry | expand

Commit Message

Brennan Vincent Sept. 28, 2024, 7:39 p.m. UTC
In gnupg-default-pinentry.patch, we patch gpg to search for its pinentry
program in ~/.guix-profile/bin by default.

guix home users might instead have pinentry in ~/.guix-home/profile/bin , so
let's check there too.

Change-Id: I85dae19809f6aff504ade9545ebc6f0b83f2f44c
---
 gnu/packages/patches/gnupg-default-pinentry.patch | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)


base-commit: 3ac69c1a757430d6dfdd37eb948ba1d6967967cc
prerequisite-patch-id: 190cf537d5350c96a329fe3baf0742cf187308bf
prerequisite-patch-id: 5450d7b82e5c1160c9663f21bad4644b51f3ca69
prerequisite-patch-id: c8abc68123e4f2c8fcfa1f2552de097f310b149c
prerequisite-patch-id: 47c71d891341ebe65d323b0ecee5e83e99aeb160
prerequisite-patch-id: e7892ac4a66728ede854ff4cd181795012780236
prerequisite-patch-id: 876cfbf9ae3cfda17809f8deb5f86aba523b0015
prerequisite-patch-id: ade24719ac6b2d1f6aab3b6559cdcc76986455cc
prerequisite-patch-id: cc25e930146f5169b2a455cafe00a2098b881cca
prerequisite-patch-id: de4804fdcb797484990fcb9028884b74d9e81906
prerequisite-patch-id: e3a8892e61c618e1d3920cf988d88554092dd8a8
prerequisite-patch-id: 0cbf33cadd71520efa7cf74cdf2a652a1d480276
prerequisite-patch-id: 82c2dd4e1bd68c72a187b05b7c6364abfd626cdf
prerequisite-patch-id: 149f45f15824dfa9984c8294b8baebef349fa58d
prerequisite-patch-id: 48ce03bfba28768acd87c048d966cd9d1050260f
prerequisite-patch-id: f3fe01a9a135cfa2751df764a052e408e3f45cc5
diff mbox series

Patch

diff --git a/gnu/packages/patches/gnupg-default-pinentry.patch b/gnu/packages/patches/gnupg-default-pinentry.patch
index a8ed613565..f9002d4d6c 100644
--- a/gnu/packages/patches/gnupg-default-pinentry.patch
+++ b/gnu/packages/patches/gnupg-default-pinentry.patch
@@ -55,11 +55,12 @@  index 4b6e46e88..f7ae68ba5 100644
  
  /* Return whether the home dir is the default one.  */
  int
-@@ -971,6 +995,7 @@ get_default_pinentry_name (int reset)
+@@ -971,6 +995,8 @@ get_default_pinentry_name (int reset)
    } names[] = {
      /* The first entry is what we return in case we found no
         other pinentry.  */
 +    { user_homedir, "/.guix-profile/bin/pinentry" },
++    { user_homedir, "/.guix-home/profile/bin/pinentry" },
      { gnupg_bindir, DIRSEP_S "pinentry" EXEEXT_S },
  #ifdef HAVE_W32_SYSTEM
      /* Try Gpg4win directory (with bin and without.) */