[bug#33283] gnu: Add python-pyelftools.

Message ID 87o9b32oyp.fsf@aikidev.net
State Accepted
Headers show
Series [bug#33283] gnu: Add python-pyelftools. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Vagrant Cascadian Nov. 5, 2018, 9:29 p.m. UTC
* gnu/packages/python.scm (python-pyelftools):
  New public variable.
---
 gnu/packages/python.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ludovic Courtès Nov. 5, 2018, 10:58 p.m. UTC | #1
Hello!

Vagrant Cascadian <vagrant@debian.org> skribis:

> * gnu/packages/python.scm (python-pyelftools):
>   New public variable.

[...]

> +    (home-page
> +     "https://github.com/eliben/pyelftools")
> +    (synopsis
> +     "Library for analyzing ELF files and DWARF debugging information")
> +    (description
> +     "Library for analyzing ELF files and DWARF debugging information")

Could you expound the description a bit?  (See
<https://www.gnu.org/software/guix/manual/en/html_node/Synopses-and-Descriptions.html>.)

Otherwise LGTM.

TIA!

Ludo’.

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 54ea0caac..c553ab319 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10578,6 +10578,29 @@  useful as a validator for JSON data.")
 (define-public python2-validictory
   (package-with-python2 python-validictory))
 
+(define-public python-pyelftools
+  (package
+    (name "python-pyelftools")
+    (version "0.25")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyelftools" version))
+       (sha256
+        (base32
+         "090vdksbz341f7ljvr0zswblw4lspa8qaiikzyjkf318arpxmil9"))))
+    (build-system python-build-system)
+    ;; Test suite requires python-setuptools
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page
+     "https://github.com/eliben/pyelftools")
+    (synopsis
+     "Library for analyzing ELF files and DWARF debugging information")
+    (description
+     "Library for analyzing ELF files and DWARF debugging information")
+    (license license:public-domain)))
+
 (define-public python-pyev
   (package
     (name "python-pyev")