[bug#34265,2/3] gnu: ocaml-migrate-parsetree: Update to 1.2.0.

Message ID 87o97vx59r.fsf@gmail.com
State Accepted
Commit b2c2c415c53d0747ca62a4807264f182d97b8382
Headers show
Series [bug#34265,1/3] gnu: dune: Update to 1.6.3. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Gabriel Hondet Feb. 1, 2019, 8:49 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-migrate-parsetree): Update to 1.2.0.
---
 gnu/packages/ocaml.scm | 28 ++++++++++++++--------------
 1 file changed, 14 insertions(+), 14 deletions(-)

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 986e435f4..a1f9e7996 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1419,24 +1419,24 @@  following a very simple s-expression syntax.")
 (define-public ocaml-migrate-parsetree
   (package
     (name "ocaml-migrate-parsetree")
-    (version "1.1.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/ocaml-ppx/"
-                                  "ocaml-migrate-parsetree/releases/download/v"
-                                  version "/ocaml-migrate-parsetree-"
-                                  version ".tbz"))
-              (sha256
-               (base32
-                "01zjp1q4hryqaxv4apkjd868fycz2kf887r6lkb6x2a545h1lh7f"))))
+    (version "1.2.0")
+    (home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url (string-append home-page ".git"))
+             (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "16kas19iwm4afijv3yxd250s08absabmdcb4yj57wc8r4fmzv5dm"))))
     (build-system dune-build-system)
     (arguments
-     `(#:tests? #f
-       #:jbuild? #t))
+     `(#:tests? #f))
     (propagated-inputs
-     `(("ocamlbuild" ,ocamlbuild)
+     `(("ocaml-ppx-derivers" ,ocaml-ppx-derivers)
+       ("ocamlbuild" ,ocamlbuild)
        ("ocaml-result" ,ocaml-result)))
-    (home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
     (synopsis "OCaml parsetree convertor")
     (description "This library converts between parsetrees of different OCaml
 versions.  For each version, there is a snapshot of the parsetree and conversion