diff mbox series

[bug#35922] gnu: add terminator

Message ID 87o93hh3p3.fsf@gnu.org
State Accepted
Headers show
Series [bug#35922] gnu: add terminator | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès June 1, 2019, 12:48 p.m. UTC
Hi Andy,

atai@atai.org skribis:

> From: Andy Tai <atai@atai.org>
>
> * gnu/packages/gnome.scm (terminator): Add at 1.91

I propose the small changes below.

However, it fails to run in this context:

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix environment --ad-hoc terminator --pure -- terminator
Traceback (most recent call last):
  File "/gnu/store/frwq9qja9m8i8dvk0lgj9mg5rnmc5377-terminator-1.91/bin/.terminator-real", line 33, in <module>
    gi.require_version('Gtk','3.0')
  File "/gnu/store/q4b7cr9j6f3g7v4xpg0zm3kkhd6l4dmg-python2-pygobject-3.28.3/lib/python2.7/site-packages/gi/__init__.py", line 130, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Gtk not available
--8<---------------cut here---------------end--------------->8---

It seems we’re missing an environment variable or something to allow
pygobject to find the GIR file for GTK+.  I’m sure this has been
addressed in other packages before, but I don’t remember how.

Anyone here?

Thanks,
Ludo’.

Comments

Andy Tai June 1, 2019, 5:42 p.m. UTC | #1
Hi, I just sent a new patch that works with Ludo's command line

./pre-inst-env guix environment --ad-hoc terminator --pure -- terminator

Thanks

On Sat, Jun 1, 2019 at 5:48 AM Ludovic Courtès <ludo@gnu.org> wrote:

> Hi Andy,
>
> atai@atai.org skribis:
>
> > From: Andy Tai <atai@atai.org>
> >
> > * gnu/packages/gnome.scm (terminator): Add at 1.91
>
> I propose the small changes below.
>
> However, it fails to run in this context:
>
> --8<---------------cut here---------------start------------->8---
> $ ./pre-inst-env guix environment --ad-hoc terminator --pure -- terminator
> Traceback (most recent call last):
>   File
> "/gnu/store/frwq9qja9m8i8dvk0lgj9mg5rnmc5377-terminator-1.91/bin/.terminator-real",
> line 33, in <module>
>     gi.require_version('Gtk','3.0')
>   File
> "/gnu/store/q4b7cr9j6f3g7v4xpg0zm3kkhd6l4dmg-python2-pygobject-3.28.3/lib/python2.7/site-packages/gi/__init__.py",
> line 130, in require_version
>     raise ValueError('Namespace %s not available' % namespace)
> ValueError: Namespace Gtk not available
> --8<---------------cut here---------------end--------------->8---
>
> It seems we’re missing an environment variable or something to allow
> pygobject to find the GIR file for GTK+.  I’m sure this has been
> addressed in other packages before, but I don’t remember how.
>
> Anyone here?
>
> Thanks,
> Ludo’.
>
>
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9775d1f82d..e0142a7fb5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7996,20 +7996,19 @@  functionality.")
        ("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("cairo" ,cairo) 
+     `(("cairo" ,cairo)
        ("gtk+" ,gtk+)
        ("gobject-introspection" ,gobject-introspection)
        ("pango" ,pango)
-       ("python" ,python-2)
        ("python2-pycairo" ,python2-pycairo)
        ("python2-pygobject" ,python2-pygobject)
        ("python2-psutil" ,python2-psutil)
        ("vte" ,vte)))
     (arguments
-     `(#:python ,python-2))
+     `(#:python ,python-2))                       ;Python 3 not supported
     (home-page "https://gnometerminator.blogspot.com/")
     (synopsis "Store and run multiple GNOME terminals in one window")
     (description
-     "Terminator allows running multiple GNOME terminals in a grid and
-tabs and supports for drag and drop re-ordering of terminals")
+     "Terminator allows you to runn multiple GNOME terminals in a grid and
+tabs, and it supports drag and drop re-ordering of terminals.")
     (license license:gpl2)))