diff mbox series

[bug#36258,1/2] gnu: monero: Update to 0.14.1.0.

Message ID 87o91wlhkw.fsf@yamatai
State Accepted
Headers show
Series [bug#36258,1/2] gnu: monero: Update to 0.14.1.0. | expand

Commit Message

Guillaume Le Vaillant July 14, 2019, 4:13 p.m. UTC
swedebugia a écrit :

> On 2019-07-14 15:32, Ludovic Courtès wrote:
> ...
>>
>> I’d rather not disable tests just because they take a long time.
>>
>> An obvious workaround would be to have the test machinery display some
>> sort of progress report or really anything that shows it’s still “doing
>> something” so that we don’t hit max-silent-timeout.
>>
>> Do you know if the build system or CTest has a flag that would make it
>> more verbose?
>
> It has:
> https://linux.die.net/man/1/ctest
>
> -V,--verbose
> Enable verbose output from tests.
> Test output is normally suppressed and only summary information is displayed.
> This option will show all test output.
>
> -VV,--extra-verbose
> Enable more verbose output from tests.
> Test output is normally suppressed and only summary information is displayed.
> This option will show even more test output.
>
> --debug
> Displaying more verbose internals of CTest.
> This feature will result in large number of output that is mostly useful for
> debugging dashboard problems.
>
> Could you test those Guillaume and see if it helps us?

Adding the '--verbose' option (patch in attachment) makes the test phase
print many things, which should fix the 'max-silent-timeout' issue.

Comments

Ludovic Courtès July 15, 2019, 10:50 a.m. UTC | #1
Hello,

Guillaume Le Vaillant <glv@posteo.net> skribis:

>> Could you test those Guillaume and see if it helps us?
>
> Adding the '--verbose' option (patch in attachment) makes the test phase
> print many things, which should fix the 'max-silent-timeout' issue.

Applied!  Now, that’s very verbose, so we might have the opposite
problem, where we’re filling the disk with a big log file…  We’ll see!

Thanks,
Ludo’.
diff mbox series

Patch

From 52c9affbebff3cf2e7d89b918060b46721fa6bd5 Mon Sep 17 00:00:00 2001
From: Guillaume Le Vaillant <glv@posteo.net>
Date: Sun, 14 Jul 2019 17:37:19 +0200
Subject: [PATCH] gnu: monero: Make tests more verbose.

Increase the verbosity of the 'check' phase to prevent 'core_tests' from
hitting 'max-silent-timeout'.

* gnu/packages/finance.scm (monero)[arguments]: Add '--verbose' option to
  'check' phase.
---
 gnu/packages/finance.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 918ba006f2..977ac9c19c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -509,7 +509,7 @@  other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
          ;; Only try tests that don't need access to network or system
          (replace 'check
            (lambda _
-             (invoke "make" "ARGS=-R 'hash|core_tests'" "test")))
+             (invoke "make" "ARGS=-R 'hash|core_tests' --verbose" "test")))
          (add-after 'check 'unit-tests
            (lambda _
              (let ((excluded-unit-tests
-- 
2.22.0