diff mbox series

[bug#40301] Fixed some issues with the patches.

Message ID 87o8ryq9h4.fsf@asu.edu
State Accepted
Headers show
Series [bug#40301] Fixed some issues with the patches. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

John Soo April 11, 2020, 4:21 p.m. UTC
Hi Guix,

I rebased these commits on master, moved the build-system field up, and
put the sha string on the same line as base32. I also moved the
definition further up in the file to avoid conflicts.

Thanks!

John

Comments

Nicolas Goaziou April 11, 2020, 7:55 p.m. UTC | #1
Hello,

John Soo <jsoo1@asu.edu> writes:

> I rebased these commits on master, moved the build-system field up, and
> put the sha string on the same line as base32. I also moved the
> definition further up in the file to avoid conflicts.

Thank you!

> +(define-public emacs-psc-ide
> +  (package
> +    (name "emacs-psc-ide")
> +    (version "0.0.0")

According to "Version:" keyword in "psc-ide.el", it is "0.1.0". Also,
you need to add a revision number, "0", or "1" at this point.

> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri
> +        (git-reference
> +         (url "https://github.com/purescript-emacs/psc-ide-emacs")
> +         (commit "7fc2b841be25f5bc5e1eb7d0634436181c38b3fe")))

The commit should be moved in a top-level `let' at the beginning of the
package definition.

> +       (file-name (git-file-name name "0.0.0"))

This should use version, along with the revision number.
> +    (synopsis "Emacs integration for PureScript's psc-ide tool")
> +    (description
> +     "Emacs integration for PureScript's psc-ide tool. Featuring:

Description should be made of full sentences. Also, it might be useful
to explain what "psc-ide" tool is.

Could you send an updated patch?

Regards,
diff mbox series

Patch

From ce0c61cbf65fbda29f5fa8ebd5c22558d71eec62 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 07:36:28 -0700
Subject: [PATCH] gnu: Add emacs-psc-ide.

* gnu/packages/emacs-xyz.scm (emacs-psc-ide): New variable.
---
 gnu/packages/emacs-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e700920266..25a854cf5a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12334,6 +12334,43 @@  keychains.  The keychain entries are displayed in a directory-like structure
 and can be consulted and modified.")
     (license license:gpl3+)))
 
+(define-public emacs-psc-ide
+  (package
+    (name "emacs-psc-ide")
+    (version "0.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/purescript-emacs/psc-ide-emacs")
+         (commit "7fc2b841be25f5bc5e1eb7d0634436181c38b3fe")))
+       (file-name (git-file-name name "0.0.0"))
+       (sha256
+        (base32 "0r0fymyai30jimm34z1cmav4wgij8ci6s1d9y7qigygfbbfrdsmj"))))
+    (build-system emacs-build-system)
+    (inputs
+     `(("emacs-company" ,emacs-company)
+       ("emacs-dash" ,emacs-dash)
+       ("emacs-flycheck" ,emacs-flycheck)
+       ("emacs-let-alist" ,emacs-let-alist)
+       ("emacs-s" ,emacs-s)
+       ("emacs-seq" ,emacs-seq)))
+    (home-page "https://github.com/purescript-emacs/psc-ide-emacs")
+    (synopsis "Emacs integration for PureScript's psc-ide tool")
+    (description
+     "Emacs integration for PureScript's psc-ide tool. Featuring:
+@itemize
+@item Completions
+@item Type at point
+@item Go to definition
+@item Automatic imports
+@item Case split
+@item Build system integration
+@item Flycheck support
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public emacs-evil-anzu
   (package
     (name "emacs-evil-anzu")
-- 
2.26.0