diff mbox series

[bug#41551] gnu: Add emacs-bm.

Message ID 87o8q5z4rw.fsf@rohleder.de
State Accepted
Headers show
Series [bug#41551] gnu: Add emacs-bm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder May 30, 2020, 5:55 p.m. UTC
Hi Marius,

you have an impressive pensum!
Thanks for the review!

Marius Bakke <marius@gnu.org> writes:
>> * gnu/packages/emacs-xyz.scm (emacs-bm): New variable.
>
> Thanks!  It LGTM but no longer applies, can you rebase it on the current
> master branch?

done.

>> +    (synopsis "Visual Bookmarks for Emacs")
>                         ^^^
>               Lowercase 'b'.

done.

>> +    (description "This package provides visible, buffer local, bookmarks and
>> +the ability to jump forward and backward to the next bookmark.")
>
> The description reads a bit weird, I wonder if...
>
>   "visible, buffer local bookmarks" (without the second comma)
>
> ...is more correct?

seems more correct, yes => done.

Comments

Marius Bakke May 30, 2020, 9:16 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> writes:

> Hi Marius,
>
> you have an impressive pensum!

Heh, not sure if that's meant as a compliment, but I'll take it.  ;-)

> Thanks for the review!

You are welcome!

[...]

> From b2a6beadb1b82a524f5ef665d747b5f5252534cb Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Sat, 30 May 2020 19:50:02 +0200
> Subject: [PATCH] gnu: Add emacs-bm.
>
> * gnu/packages/emacs-xyz.scm (emacs-bm): New variable.

Applied, thanks!
diff mbox series

Patch

From b2a6beadb1b82a524f5ef665d747b5f5252534cb Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sat, 30 May 2020 19:50:02 +0200
Subject: [PATCH] gnu: Add emacs-bm.

* gnu/packages/emacs-xyz.scm (emacs-bm): New variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6d82e1921c..9cf4cdd6a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1918,6 +1918,26 @@  code@{emacs-wiki.el}, it facilitates using hyperlinks and doing full-text
 searches.  Unlike code@{emacs-wiki.el}, it can be combined with any format.")
     (license license:gpl1+)))
 
+(define-public emacs-bm
+  (package
+    (name "emacs-bm")
+    (version "201905")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/joodland/bm.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "180b3rc13asrmsdh7v405d54jkrininvaj52xhp71vw91ng51dkn"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/joodland/bm")
+    (synopsis "Visual bookmarks for Emacs")
+    (description "This package provides visible, buffer local bookmarks and
+the ability to jump forward and backward to the next bookmark.")
+    (license license:gpl2+)))
+
 (define-public emacs-calfw
   (package
     (name "emacs-calfw")
-- 
2.26.2