diff mbox series

[bug#41459,1/4] gnu: Add python-py-cpuinfo

Message ID 87o8q1dcug.fsf@alice.lan
State Accepted
Headers show
Series [bug#41459,1/4] gnu: Add python-py-cpuinfo | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Edouard Klein June 2, 2020, 9:41 a.m. UTC
* gnu/packages/python-xyz.scm (python-py-cpuinfo): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Marius Bakke June 22, 2020, 7:33 p.m. UTC | #1
Edouard Klein <edk@beaver-labs.com> writes:

> * gnu/packages/python-xyz.scm (python-py-cpuinfo): New variable.

Applied with a minor tweak to the description.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6aa666430a..5cd3abd956 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19458,6 +19458,25 @@  using “=” characters.  However this conveys no benefit so many protocols
 choose to use Base64 without the “=” padding.")
     (license license:asl2.0)))
 
+(define-public python-py-cpuinfo
+  (package
+    (name "python-py-cpuinfo")
+    (version "5.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "py-cpuinfo" version))
+       (sha256
+        (base32
+         "0045y6832gqjg63jmw0qj2jwyypgjwr7sfdq3lfv49b6fxpl5xic"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/workhorsy/py-cpuinfo")
+    (synopsis "Get CPU info with Python")
+    (description
+     "This module returns the CPU info by using the best sources of information for
+ your Operating System.")
+    (license license:expat)))
+
 (define-public python-canonicaljson
   (package
     (name "python-canonicaljson")