diff mbox series

bug#45003: [PATCH] gnu: poetry: Fix a problem with a dependency.

Message ID 87o8jaimtw.fsf@gnu.org
State Accepted
Headers show
Series bug#45003: [PATCH] gnu: poetry: Fix a problem with a dependency. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Marius Bakke Dec. 3, 2020, 9:47 p.m. UTC
Tanguy Le Carrour <tanguy@bioneland.org> skriver:

> * gnu/packages/python-xyz.scm (poetry)[arguments]: Relax version constraints
> for python-packaging.

Applied, thanks!

Note: I tried to do this:
But the test suite actually picks the 'python-packaging' that is
propagated from 'pytest', and promptly fails.

Updating packaging alone is also a staging-level change, so I did not
dig much further.  But there is some room for improvement here.  Maybe
by (setenv "PYTHONPATH" (string-append ".:" (getenv "PYTHONPATH"))) ?

I also wonder whether pytest needs to propagate packaging at all, or if
wrapping is enough.  Do you know how common it is to "import pytest" or
"from pytest import foo", and whether those code paths would need
'packaging'?

Anyway, future problems!  Thanks for maintaining Poetry.  :-)

Comments

Tanguy LE CARROUR Dec. 4, 2020, 7:23 a.m. UTC | #1
Hi Marius!


Excerpts from Marius Bakke's message of December 3, 2020 10:47 pm:
> Tanguy Le Carrour <tanguy@bioneland.org> skriver:
> 
>> * gnu/packages/python-xyz.scm (poetry)[arguments]: Relax version constraints
>> for python-packaging.
> 
> Applied, thanks!

Thanks!


> Note: I tried to do this:
> […]
> But the test suite actually picks the 'python-packaging' that is
> propagated from 'pytest', and promptly fails.
> 
> Updating packaging alone is also a staging-level change, so I did not
> dig much further.  But there is some room for improvement here.  Maybe
> by (setenv "PYTHONPATH" (string-append ".:" (getenv "PYTHONPATH"))) ?
> 
> I also wonder whether pytest needs to propagate packaging at all, or if
> wrapping is enough.  Do you know how common it is to "import pytest" or
> "from pytest import foo", and whether those code paths would need
> 'packaging'?
> 
> Anyway, future problems!  Thanks for maintaining Poetry.  :-)

I would hardly call it "maintaining"! It's been more like a struggle! ^_^'
Now that the situation has (hopefully) stabilized, I can spend some time
on the "poetry build system".

Thank you again for your precious help and your time!
Tanguy LE CARROUR Dec. 4, 2020, 7:35 a.m. UTC | #2
*Oups*, I sent my message to quickly…


Excerpts from Marius Bakke's message of December 3, 2020 10:47 pm:
> Updating packaging alone is also a staging-level change, so I did not
> dig much further.  But there is some room for improvement here.  Maybe
> by (setenv "PYTHONPATH" (string-append ".:" (getenv "PYTHONPATH"))) ?

Actually, I noticed some weird things when using Poetry, that might be
related to PYTHONPATH. Even if it was installed in its own profile, it
was using python packages installed outside of it. Can't remember for
sure, but I think it was `virtualenv`.
I had to unset my PYTHONPATH to make it use the ones installed in the profile.
But, now that the versions are the same in the default profile and in
this dedicated Poetry profile, everything seems to be working just fine.


> I also wonder whether pytest needs to propagate packaging at all, or if
> wrapping is enough.  Do you know how common it is to "import pytest" or
> "from pytest import foo", and whether those code paths would need
> 'packaging'?

Usually, one would only do this in the test suite, or in a package that
extends pytest behaviour. At least it's what I see from the 450,942 results
I've found on Github. But I have to confess that I did not go through
all of them! ^_^'

Regards
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bffb643258..ce4695a956 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16003,17 +16003,15 @@  several utilities, as well as an API for building localization tools.")
 (define-public python-packaging
   (package
     (name "python-packaging")
-    (version "20.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "packaging" version))
-        ;; XXX: The URL in the patch file is wrong, it should be
-        ;; <https://github.com/pypa/packaging/pull/256>.
-        (patches (search-patches "python-packaging-test-arch.patch"))
-        (sha256
-         (base32
-          "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))
+    ;; Note: when updating this, be careful not to change the 'bootstrap'
+    ;; variant below, which can only be updated on 'core-updates'.
+    (version "20.4")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "packaging" version))
+              (sha256
+               (base32
+                "1y3rc1ams1i25calk6b9jf1gl85ix5a23a146swjvhdr8x7zfms3"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -16046,25 +16044,26 @@  information.")
 ;; Variants with minimal dependencies, for bootstrapping Pytest.
 (define-public python-packaging-bootstrap
   (hidden-package
-   (package/inherit
-    python-packaging
-    (name "python-packaging-bootstrap")
-    (native-inputs '())
-    (propagated-inputs
-     `(("python-pyparsing" ,python-pyparsing)))
-    (arguments '(#:tests? #f)))))
+   (package
+     (inherit python-packaging)
+     (version "20.0")
+     (source (origin
+               (method url-fetch)
+               (uri (pypi-uri "packaging" version))
+               ;; XXX: The URL in the patch file is wrong, it should be
+               ;; <https://github.com/pypa/packaging/pull/256>.
+               (patches (search-patches "python-packaging-test-arch.patch"))
+               (sha256
+                (base32
+                 "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))
+     (name "python-packaging-bootstrap")
+     (native-inputs '())
+     (propagated-inputs
+      `(("python-pyparsing" ,python-pyparsing)))
+     (arguments '(#:tests? #f)))))
 
 (define-public python2-packaging-bootstrap
-  (hidden-package
-   (package/inherit
-    python2-packaging
-    (name "python2-packaging-bootstrap")
-    (native-inputs '())
-    (propagated-inputs
-     `(("python-pyparsing" ,python2-pyparsing)))
-    (arguments
-     `(#:tests? #f
-       ,@(package-arguments python2-packaging))))))
+  (package-with-python2 python-packaging-bootstrap))
 
 (define-public python-relatorio
   (package