diff mbox series

[bug#53195] gnu: nautilus: Fix build with libportal-0.5.

Message ID 87o84iuj8u.fsf@gmx.com
State Accepted
Headers show
Series [bug#53195] gnu: nautilus: Fix build with libportal-0.5. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pierre Langlois Jan. 11, 2022, 8:05 p.m. UTC
Hi Guix!

I noticed nautilus fails to build and saw there was a patch upstream so
here's a patch! I've also added a patch to update nautilus to 41.1 and
adjust its style while I was there. The patch will only be in nautilus
42 though.

These patches are pretty trivial so I'll push them in the next few hours
unless somebody beats me to it :-).

Thanks,
Pierre

Comments

Pierre Langlois Jan. 12, 2022, 12:24 a.m. UTC | #1
Pierre Langlois <pierre.langlois@gmx.com> writes:

> [[PGP Signed Part:Undecided]]
> Hi Guix!
>
> I noticed nautilus fails to build and saw there was a patch upstream so
> here's a patch! I've also added a patch to update nautilus to 41.1 and
> adjust its style while I was there. The patch will only be in nautilus
> 42 though.
>
> These patches are pretty trivial so I'll push them in the next few hours
> unless somebody beats me to it :-).

Pushed with

  a9678953ea0be55fb40500066ddeb2451298a190
  5b0a7fd9ad3f3e3fbb89bd19dc90490f4bc5ca4a
  857dc1cc64aa365cd6ba79a55b1e8f2f667c5d20

And gnome builds again! :-)

Thanks,
Pierre
diff mbox series

Patch

From 625c25732ce7e7bc28bda9164c6145993b3689a4 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Tue, 11 Jan 2022 19:59:23 +0000
Subject: [PATCH 3/3] gnu: nautilus: Adjust style.

* gnu/packages/gnome.scm (nautilus)[native-inputs, inputs]: Remove labels.
---
 gnu/packages/gnome.scm | 56 +++++++++++++++++++++---------------------
 1 file changed, 28 insertions(+), 28 deletions(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b621f6c43a..b30edcc736 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9135,35 +9135,35 @@  (define-public nautilus
        ;;   Settings schema 'org.gnome.nautilus.preferences' is not installed
        #:tests? #f))
     (native-inputs
-     `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
-       ("glib:bin" ,glib "bin")         ; for glib-mkenums, etc.
-       ("gobject-introspection" ,gobject-introspection)
-       ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)))
+     (list desktop-file-utils     ; for update-desktop-database
+           `(,glib "bin")         ; for glib-mkenums, etc.
+           gobject-introspection
+           intltool
+           pkg-config))
     (inputs
-     `(("dconf" ,dconf)
-       ("gexiv2" ,gexiv2)
-       ("gvfs" ,gvfs)
-       ("exempi" ,exempi)
-       ("gnome-desktop" ,gnome-desktop)
-       ("gnome-autoar" ,gnome-autoar)
-       ("gst-plugins-base" ,gst-plugins-base)
-       ("json-glib" ,json-glib)
-       ("libhandy" ,libhandy)
-       ("libportal" ,libportal)
-       ("libseccomp" ,libseccomp)
-       ("libselinux" ,libselinux)
-       ("libsoup" ,libsoup-minimal-2) ; to satisfy tracker dependencies
-       ("tracker" ,tracker)
-       ("tracker-miners" ,tracker-miners)
-       ;; XXX: gtk+ is required by libnautilus-extension.pc
-       ;;
-       ;; Don't propagate it to reduces "profile pollution" of the 'gnome' meta
-       ;; package.  See:
-       ;; <http://lists.gnu.org/archive/html/guix-devel/2016-03/msg00283.html>.
-       ("gtk+" ,gtk+)
-       ("libexif" ,libexif)
-       ("libxml2" ,libxml2)))
+     (list dconf
+           gexiv2
+           gvfs
+           exempi
+           gnome-desktop
+           gnome-autoar
+           gst-plugins-base
+           json-glib
+           libhandy
+           libportal
+           libseccomp
+           libselinux
+           libsoup-minimal-2 ; to satisfy tracker dependencies
+           tracker
+           tracker-miners
+           ;; XXX: gtk+ is required by libnautilus-extension.pc
+           ;;
+           ;; Don't propagate it to reduces "profile pollution" of the 'gnome' meta
+           ;; package.  See:
+           ;; <http://lists.gnu.org/archive/html/guix-devel/2016-03/msg00283.html>.
+           gtk+
+           libexif
+           libxml2))
     (native-search-paths
      (list (search-path-specification
             (variable "NAUTILUS_EXTENSION_PATH")
--
2.34.0