diff mbox series

[bug#53851] gnu: Add emacs-latex-preview-pane.

Message ID 87o83i6409.fsf@gmail.com
State Accepted
Headers show
Series [bug#53851] gnu: Add emacs-latex-preview-pane. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jai Vetrivelan Feb. 7, 2022, 4:22 p.m. UTC

Comments

Nicolas Goaziou Feb. 8, 2022, 12:16 a.m. UTC | #1
Hello,

Jai Vetrivelan <jaivetrivelan@gmail.com> writes:

> Subject: [PATCH] gnu: Add emacs-latex-preview-pane.

Thank you.
>
> * gnu/packages/emacs-xyz.scm (emacs-latex-preview-pane): new variable.

Nitpick: capitalize "New".

> +       (arguments
> +        ;; The welcome and error message templates are in .txt format.
> +        '(#:include '("\\.el$" "\\.txt$")))

You can switch to G-expressions:

    (arguments
     (list
      #:include #~(list "\\.el$" "\\.txt$")))

This is a bit more verbose, tho.

> +       (home-page "https://www.emacswiki.org/emacs/LaTeXPreviewPane")

Why is the home-page pointing to EmacsWiki? Shouldn't it point to the
repository instead?

> +       (synopsis "Makes LaTeX editing less painful by providing a updatable
> +preview pane")

I suggest something shorter and more neutral:

    "Preview pane to ease LaTeX editing in Emacs"

> +       (description "@code{latex-preview-pane} is a minor mode for Emacs that
> +enables you to preview your LaTeX files directly in Emacs. It supports PDF
> +previews, your choice of pdflatex or xelatex, and it highlights errors in your
> +LaTeX buffer.")

Nitpick: I would remove all "your" references…

  "@code{latex-preview-pane} is a minor mode for previewing LaTeX files
  directly in Emacs. It supports PDF previews, with either
  @command{pdflatex} or @command{xelatex}, and highlights errors in the
  LaTeX buffer.

Could you send an updated patch?

Regards,
diff mbox series

Patch

From 470a2605d4adf98e77aee9171e4292e9e7c41561 Mon Sep 17 00:00:00 2001
From: Jai Vetrivelan <jaivetrivelan@gmail.com>
Date: Mon, 7 Feb 2022 21:44:36 +0530
Subject: [PATCH] gnu: Add emacs-latex-preview-pane.

* gnu/packages/emacs-xyz.scm (emacs-latex-preview-pane): new variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bec613e381..5251e503c9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19018,6 +19018,34 @@  (define-public emacs-lacarte
     (description "Execute menu items as commands, with completion.")
     (license license:gpl3)))
 
+(define-public emacs-latex-preview-pane
+  (let ((commit "5297668a89996b50b2b62f99cba01cc544dbed2e")
+        (revision "0"))
+      (package
+       (name "emacs-latex-preview-pane")
+       (version (git-version "20151021" revision commit))
+       (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jsinglet/latex-preview-pane")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1m4f5p53275k8i9p0y105kkrp9nx1bwn6726my9s5dwnjhr5dnp2"))))
+       (build-system emacs-build-system)
+       (arguments
+        ;; The welcome and error message templates are in .txt format.
+        '(#:include '("\\.el$" "\\.txt$")))
+       (home-page "https://www.emacswiki.org/emacs/LaTeXPreviewPane")
+       (synopsis "Makes LaTeX editing less painful by providing a updatable
+preview pane")
+       (description "@code{latex-preview-pane} is a minor mode for Emacs that
+enables you to preview your LaTeX files directly in Emacs. It supports PDF
+previews, your choice of pdflatex or xelatex, and it highlights errors in your
+LaTeX buffer.")
+       (license license:gpl3+))))
+
 (define-public emacs-isearch-prop
   (let ((commit "4a2765f835dd115d472142da05215c4c748809f4")
         (revision "2"))

base-commit: 4396fef04717eebb061b2c808087ca638f87a826
-- 
2.34.0