diff mbox series

[bug#54078,1/3] gnu: add libaml

Message ID 87o82xpgd8.fsf_-_@disroot.org
State New
Headers show
Series [bug#54078,1/3] gnu: add libaml | expand

Commit Message

kitzman Feb. 23, 2022, 6:50 p.m. UTC

diff mbox series

Patch

From ac8f0bdbc92a834bbc96b3e676cc58059afc3633 Mon Sep 17 00:00:00 2001
From: kitzman <kitzman@disroot.org>
Date: Wed, 23 Feb 2022 20:41:17 +0200
Subject: [PATCH 1/3] gnu: add libaml

---
 gnu/packages/linux.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1c514c3cec..27c54f90b0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8814,3 +8814,33 @@  (define-public libgpiod
     (license (list license:lgpl2.1+   ;; libgpiod
                    license:gpl2+      ;; gpio-tools
                    license:lgpl3+)))) ;; C++ bindings
+
+(define-public libaml
+  (package
+    (name "libaml")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/any1/aml")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "aml" (string-append "v" version)))
+              (sha256
+               (base32
+                "0mxmzlhiv88hm4sf8kyawyrml8qy1xis019hdyb5skl9g95z9yyf"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://github.com/any1/aml")
+    (synopsis "Another/Andri's main loop")
+    (description "The @code{aml} library provides a portable event loop for C,
+with the following features:
+@enumerate
+@item file descriptor event handlers
+@item timers and tickers
+@item signal handlers
+@item idle dispatch callbacks
+@item thread pool support
+@end enumerate
+")
+    (license license:isc)))
-- 
2.32.0