diff mbox series

[bug#56240] gnu: Add ubench-h

Message ID 87o7yf2mz3.fsf@gmail.com
State New
Headers show
Series [bug#56240] gnu: Add ubench-h | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov June 26, 2022, 8:23 p.m. UTC
Hello,

this patch adds "ubench.h"[1] under the name "ubench-h".
Thanks,

- Artyom

References:
1. https://github.com/sheredom/ubench.h

Comments

Artyom V. Poptsov July 6, 2022, 8:33 p.m. UTC | #1
Hello Guixers,

I see that my 'utest-h' patch was merged recently (hooray!)

It would be nice if someone could do a patch-review for my 'ubench-h'
patch as well.  ;-)

Thanks!

- Artyom
diff mbox series

Patch

From 032c55ab247ce50dfe22fe37b742634c69ab4f94 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 26 Jun 2022 23:19:38 +0300
Subject: [PATCH] gnu: Add ubench-h.

* gnu/packages/c.scm (ubench-h): New variable.
---
 gnu/packages/c.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index bcacccfd03..0d929ff892 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1166,3 +1166,39 @@  string.h, but with a utf8* prefix instead of the str* prefix.")
       (synopsis "Single header unit testing framework for C and C++")
       (description "A simple one header solution to unit testing for C/C++.")
       (license license:unlicense))))
+
+(define-public ubench-h
+  ;; The latest commit is used as there is no release.
+  (let ((commit "bcf152d83c3495242aa46df69cecdc9f3fbdf687") (revision "0"))
+    (package
+      (name "ubench-h")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/sheredom/ubench.h")
+                      (commit commit)))
+                (file-name (git-file-name "ubench.h" version))
+                (sha256
+                 (base32
+                  "0sdnycxmrp78zhwydqbca985c3cg7px3n90vfs8c3agzra7xrhsi"))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:phases (modify-phases %standard-phases
+                    (delete 'build)
+                    (delete 'configure)
+                    (replace 'check
+                      (lambda* (#:key tests? #:allow-other-keys)
+                        (when tests?
+                          (with-directory-excursion "test"
+                                                    (invoke "cmake" ".")
+                                                    (invoke "make")))))
+                    (replace 'install
+                      (lambda* (#:key outputs #:allow-other-keys)
+                        (let ((out (assoc-ref outputs "out")))
+                          (install-file "ubench.h"
+                                        (string-append out "/include"))))))))
+      (home-page "https://github.com/sheredom/ubench.h")
+      (synopsis "Single header benchmark framework for C and C++")
+      (description "A simple one header solution to benchmarking for C/C++.")
+      (license license:unlicense))))
-- 
2.25.1