diff mbox series

[bug#57192] Add python-ephem.

Message ID 87o7wnwruf.fsf@contorta
State Accepted
Headers show
Series [bug#57192] Add python-ephem. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vagrant Cascadian Aug. 14, 2022, 1:12 a.m. UTC
This is arguably replaced by python-skyfield, though there are projects
that use the older python-ephem interfaces still.

Comments

Björn Höfling Sept. 21, 2022, 8:11 p.m. UTC | #1
On Sat, 13 Aug 2022 18:12:40 -0700
Vagrant Cascadian <vagrant@debian.org> wrote:

> This is arguably replaced by python-skyfield, though there are
> projects that use the older python-ephem interfaces still.
> 

Pushed as 97e719593045f5541d062aece1a25379be56d24d.

Thanks,

Björn
diff mbox series

Patch

From c4c9fbc6c6ac5a0b65203b60aa0353e0f047fddf Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sat, 13 Aug 2022 16:25:31 -0700
Subject: [PATCH 2/3] gnu: Add python-ephem.

* gnu/packages/astronomy.scm (python-ephem): New Variable.
---
 gnu/packages/astronomy.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 87c290f58f..13ffdd74d3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -29,6 +29,7 @@  (define-module (gnu packages astronomy)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
@@ -1054,6 +1055,29 @@  (define-public python-cdflib
 @end itemize\n")
     (license license:expat)))
 
+(define-public python-ephem
+  (package
+    (name "python-ephem")
+    (version "4.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "ephem" version))
+              (sha256
+               (base32
+                "0smmm3l8csnw9rrimh8mpyjrm80jaafjl184spnji98vk22qd8bz"))))
+    (build-system python-build-system)
+    (native-inputs (list tzdata))
+    (home-page "https://rhodesmill.org/pyephem/")
+    (synopsis "Compute positions of the planets and stars")
+    (description
+     "PyEphem provides an @code{ephem} Python package for performing
+high-precision astronomy computations.
+
+The name ephem is short for the word ephemeris, which is the traditional term
+for a table giving the position of a planet, asteroid, or comet for a series
+of dates.")
+    (license license:expat)))
+
 (define-public python-photutils
   (package
     (name "python-photutils")
-- 
2.35.1