diff mbox series

[bug#66378] gnu: Add rust-wayland-protocols-0.30.

Message ID 87o7hbnvtw.fsf@gmail.com
State New
Headers show
Series [bug#66378] gnu: Add rust-wayland-protocols-0.30. | expand

Commit Message

Aleksandr Vityazev Oct. 7, 2023, 12:02 a.m. UTC
* gnu/packages/crates-io.scm (rust-wayland-protocols-0.30): New variable.
---
 gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: a7e6b4c98b97921ab695218f9b89be4f1ded48c9
prerequisite-patch-id: ec4a09723b91089c8eb5b5269ae81272bb4d81b4
prerequisite-patch-id: 9680399593e3dcdb5b10ee646023efd1215942d9
prerequisite-patch-id: 66497a0079d0077e7b5001707d8211c525ea7193
prerequisite-patch-id: 4f512542ae5806d47054e063e3dd1df66258c530
prerequisite-patch-id: 48abb1e84ca8d85b23794222f8fa5b4d2dfa4699
prerequisite-patch-id: a7fdd2f87131ad73865389152d4a826df24fcae7
prerequisite-patch-id: 1600413a45a50114906f4390653c3fbb7f536a4c
prerequisite-patch-id: 51e95882782a53eda933e884fb5e80487ba52b9f
prerequisite-patch-id: 177b2873f4e77585c464ac3d24bec78d58f128bd
prerequisite-patch-id: 631a6785018f999fcbf7e22fb8e2aae9329ced55
prerequisite-patch-id: 1bd1b328f9e3c7119fed731ffd7e7d87ac33f0c2
prerequisite-patch-id: 79105270952c22f07255cb315da1db44f505b07b
prerequisite-patch-id: 9c5af3baa3dac6233837fb6eb0b7467b969caff4
prerequisite-patch-id: 1156b461c8622b5071656309b05c026abab0f277
prerequisite-patch-id: 8a5e3746b5092496884d50ef4359148ac9349a83
prerequisite-patch-id: 579e44cb67db2d0d3c6232c7c306457a0b5a1a27
prerequisite-patch-id: f5dc3c2782749512e23becb166db7aafacd0be1f
prerequisite-patch-id: 41717fac7367d7e596c093548408ab4bb7d11575
prerequisite-patch-id: 82761b9bede107314f9e75282e1851da281e1d53
prerequisite-patch-id: 4eaffd8b1788833c76590916476337e55ae234b0
prerequisite-patch-id: b501999eff4662ed2917dba3b934abd1a5e2252a
prerequisite-patch-id: d2b947c72b82c6366d8164f1d732a4d25c6cb4fa
prerequisite-patch-id: e1df80a774d3de676f01f262c68f506b0bc1ed92
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8b10a99034..2b09ee8f9d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -77481,6 +77481,33 @@  (define-public rust-wayland-client-0.30
 of the wayland protocol, client side.")
     (license license:expat)))
 
+(define-public rust-wayland-protocols-0.30
+  (package
+    (name "rust-wayland-protocols")
+    (version "0.30.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "wayland-protocols" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0kcvvli38gdjb9c7dpa2s0ix4nnqfq7n2bbc39370kx9bhg10a1v"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-bitflags" ,rust-bitflags-1)
+        ("rust-wayland-backend" ,rust-wayland-backend-0.1)
+        ("rust-wayland-client" ,rust-wayland-client-0.30)
+        ("rust-wayland-scanner" ,rust-wayland-scanner-0.30)
+        ("rust-wayland-server" ,rust-wayland-server-0.30))))
+    (home-page "https://github.com/smithay/wayland-rs")
+    (synopsis "Generated API for the officials wayland protocol extensions")
+    (description "This package provides generated API for the officials wayland
+protocol extensions.")
+    (license license:expat)))
+
 (define-public rust-wayland-scanner-0.30
   (package
     (name "rust-wayland-scanner")