diff mbox series

[bug#68142] gnu: Add python-hdf5storage.

Message ID 87o7e82cjv.fsf@troyfigiel.com
State New
Headers show
Series [bug#68142] gnu: Add python-hdf5storage. | expand

Commit Message

Troy Figiel Dec. 30, 2023, 10:44 a.m. UTC
* gnu/packages/python-xyz.scm (python-hdf5storage): New variable.

Change-Id: If54c5f4b634658854bbe9312dce194643fe23733
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: f24b14767d362a84e6469682b4fe303b50f4b589

Comments

Mathieu Othacehe Jan. 9, 2024, 8:53 a.m. UTC | #1
> * gnu/packages/python-xyz.scm (python-hdf5storage): New variable.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2afce6c667..594059f25e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2279,6 +2279,30 @@  (define-public python-h5py
 concepts.")
     (license license:bsd-3)))
 
+(define-public python-hdf5storage
+  (package
+    (name "python-hdf5storage")
+    (version "0.1.19")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hdf5storage" version))
+       (sha256
+        (base32 "11pgxsqap9l7jsf52649q9mpj8a0w6p9im929lpr9s26ynnnn6ks"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-h5py python-numpy))
+    (native-inputs (list python-nose))
+    (home-page "https://github.com/frejanordsiek/hdf5storage")
+    (synopsis "Read and write Python data types from and to HDF5 files")
+    (description
+     "This Python package provides high-level utilities to read and write a
+variety of Python types from and to @acronym{HDF5, Hierarchical Data Format}
+formatted files.  This package also provides support for MATLAB MAT v7.3
+formatted files, which are HDF5 files with a different extension and some
+extra metadata.  Because HDF5 and MAT files might need to be read from
+untrusted sources, pickling is avoided in this package.")
+    (license license:bsd-2)))
+
 (define-public python-hjson
   ;; Using commit from master branch as the PyPI version does not contain
   ;; the hjson/tests/ directory.